Closed Bug 830303 Opened 8 years ago Closed 8 years ago

Fix plugin-container spawning on BSD after bug 753046

Categories

(Core :: IPC, defect)

All
OpenBSD
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: gaston, Assigned: gaston)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 753046 had a wrong chunk : in https://hg.mozilla.org/mozilla-central/rev/b6f7fe8e2363

    1.31 -# ifdef OS_LINUX
    1.32 -#  ifdef MOZ_WIDGET_ANDROID
    1.33 +# if defined(OS_LINUX) || defined(OS_BSD)
    1.34 +#  if defined(MOZ_WIDGET_ANDROID) || defined(OS_BSD)
    1.35          path += "/lib";
    1.36  #  endif  // MOZ_WIDGET_ANDROID

With that change, the code adds /lib to the native GRE path - while it shouldnt, the libs are installed in the same dir as ffx/etc. Consequence : spawning plugin-container is broken, since the LD_LIBRARY_PATH doesnt contain the correct path to libxul/libxpcom.

This was probably an oversight.
Assignee: nobody → landry
Attachment #701752 - Flags: review?(jones.chris.g)
Attachment #701752 - Flags: review?(jones.chris.g) → review+
Comment on attachment 701752 [details] [diff] [review]
Remove bogus OS_BSD

[Approval Request Comment]
Regression caused by (bug #): 753046
User impact if declined: external plugin fail to load on *BSD
Testing completed (on m-c, etc.): tested here, patch against 19.0b1 & 18.0 confirmed to fix the issue
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #701752 - Flags: approval-mozilla-release?
Attachment #701752 - Flags: approval-mozilla-beta?
Attachment #701752 - Flags: approval-mozilla-aurora?
Comment on attachment 701752 [details] [diff] [review]
Remove bogus OS_BSD

Approving for Aurora/Beta since this is NPOTB. Will have an answer for you on release tomorrow around noon PT. Would be great if you were available to uplift at that time.
Attachment #701752 - Flags: approval-mozilla-beta?
Attachment #701752 - Flags: approval-mozilla-beta+
Attachment #701752 - Flags: approval-mozilla-aurora?
Attachment #701752 - Flags: approval-mozilla-aurora+
Attachment #701752 - Flags: approval-mozilla-release? → approval-mozilla-release+
https://hg.mozilla.org/mozilla-central/rev/80b36fe6cf0c
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Keywords: verifyme
I'm sorry i wont be able to push to -release branch right now (disk full, cant checkout a clone..) - can anyone push it on my behalf ?
Keywords: checkin-needed
I have tried for several hours to install FF 19beta2 on OpenBSD 5.2 without success. I only managed to install FF 13, which was found on the OpenBSD repositories.

Landry, could you please verify this?
As i said in comment 3, it works for me now. 

You'd have to run OpenBSD-current to test FF19.0b1 or FF18, and i'd have to send you a package with the fix :)
Or with -current you can grab http://ftp.openbsd.org/pub/OpenBSD/snapshots/packages/i386/firefox-18.0p0.tgz and install it with pkg_add - only i386 atm, the amd64 package didnt reach the ftp yet.

Or if you really want to build/verify it yourself, i can send you all the instructions to build the port from my git repo at http://rhaalovely.net/cgit/mozilla-firefox/ ....
Hi Landry,

Can you please confirm that this is now fixed for you with the following builds?
* Firefox 18.0.1
* Firefox 19.0b2
* Firefox 20.0a2 (latest)
* Firefox 21.0a1 (latest)

Thanks
Well, seems it wont be fixed in pristine 18.0.1 since for some reason my push wasnt in time for the candidate build1 (http://hg.mozilla.org/releases/mozilla-release/log/eecd28b7ba09/ipc/glue/GeckoChildProcessHost.cpp doesnt have it, and it's what's in 18.0.1..)

As for the others, it should be okay, i just have to build & test them, but m-c is busted for me atm because of bug 784841.

Consider it fixed anyway, as i'm shipping builds to my users with the patch backported...
Hmm...okay, please keep us updated Landry.
(In reply to Landry Breuil (:gaston) from comment #12)
> Well, seems it wont be fixed in pristine 18.0.1 since for some reason my
> push wasnt in time for the candidate build1
> (http://hg.mozilla.org/releases/mozilla-release/log/eecd28b7ba09/ipc/glue/
> GeckoChildProcessHost.cpp doesnt have it, and it's what's in 18.0.1..)
> 
> As for the others, it should be okay, i just have to build & test them, but
> m-c is busted for me atm because of bug 784841.
> 
> Consider it fixed anyway, as i'm shipping builds to my users with the patch
> backported...

Looks like we didn't comment here, but yeah - this didn't make our release sadly, as it landed after our go and wasn't a hard blocker for release. It is on mozilla-release however, for others pulling the repo.
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.