Last Comment Bug 830321 - Click events are not working properly in Firefox 18
: Click events are not working properly in Firefox 18
Status: RESOLVED DUPLICATE of bug 829921
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 18 Branch
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://jsfiddle.net/dmitrismirnov/kSYqd/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 06:47 PST by dmitri.smirnov
Modified: 2013-01-14 09:11 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Firefox 18 click event issue (1.57 KB, text/plain)
2013-01-14 06:47 PST, dmitri.smirnov
no flags Details

Description dmitri.smirnov 2013-01-14 06:47:21 PST
Created attachment 701779 [details]
Firefox 18 click event issue

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

click events are not fired if some combination of HTML and CSS
in same time mouseup event is fired.
it was working in FF 17, and working in all other browsers
Example could be found here: http://jsfiddle.net/dmitrismirnov/kSYqd/4/
or in the attachment


Actual results:

some elements does not react on click events


Expected results:

click handler should be called if supposed to be.
Comment 1 Alice0775 White 2013-01-14 09:09:47 PST
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f7c89de3ab43
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120915201302
Bad:
http://hg.mozilla.org/mozilla-central/rev/b3f462d96fb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916161603
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=b3f462d96fb5


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/33087122ace7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916022601
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ee831a85d12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916033402
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33087122ace7&tochange=6ee831a85d12

In local build
Last Good: 0ee3959754f8
First Bad: 6ee831a85d12

Triggered by;
6ee831a85d12	Matt Woodrow — Bug 788044 - Make transformed frames the reference frame for their display list tree. r=roc


And I confirmed that it works as expected in latest Nightly21.0a1 tinderbox build.

*** This bug has been marked as a duplicate of bug 829921 ***
Comment 2 Alice0775 White 2013-01-14 09:11:59 PST
s/latest Nightly21.0a1 tinderbox build/latest Nightly21.0a1 inbound tinderbox build/

Note You need to log in before you can comment on or make changes to this bug.