Closed Bug 830396 Opened 8 years ago Closed 8 years ago

add back nsIDOMCSSValueList

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox19 --- unaffected
firefox20 + fixed
firefox21 --- fixed

People

(Reporter: tbsaunde, Assigned: tbsaunde)

References

Details

(Keywords: addon-compat)

Attachments

(1 file, 2 obsolete files)

No description provided.
Attached patch patch (obsolete) — Splinter Review
Attachment #701855 - Flags: review?(bzbarsky)
Comment on attachment 701855 [details] [diff] [review]
patch

Can you add a test to dom/tests/mochitest/chrome/file_DOM_element_instanceof.xul ?

I would expect that to fail without the classinfo bits I mentioned on irc...
Blocks: 798567
Attachment #701962 - Attachment is obsolete: true
Attachment #701855 - Attachment is obsolete: true
Attachment #701855 - Flags: review?(bzbarsky)
(In reply to Boris Zbarsky (:bz) from comment #2)
> Comment on attachment 701855 [details] [diff] [review]
> patch
> 
> Can you add a test to
> dom/tests/mochitest/chrome/file_DOM_element_instanceof.xul ?

that seems to be tricky because it appears the iframe doesn't get a pres shell, so its hard to get something that should be a CSSValueList...
Attachment #702149 - Flags: review?(bzbarsky)
Comment on attachment 702149 [details] [diff] [review]
bug 830396 - add back nsIDOMCSSValueList

>+  ok(cs.getPropertyCSSValue("cursor") instanceof nsIDOMCSSValueList,
>+  "cSSValueList should be a nsIDOMCSSValueList");

Please fix the indent and capitalize that first 'C'.

r=me
Attachment #702149 - Flags: review?(bzbarsky) → review+
Note that we'll want this on Aurora 20 too.
Addons use it.  See comments in the bug this blocks.
Comment on attachment 702149 [details] [diff] [review]
bug 830396 - add back nsIDOMCSSValueList

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 798567 
User impact if declined: Breaks some extensions
Testing completed (on m-c, etc.): Passes tests
Risk to taking this patch (and alternatives if risky): Just let the extensions
   involved deal.  Some already have.
String or UUID changes made by this patch: Effectively changes the UUID of
   nsIDOMCSSValueList compared to Firefox 19, but compared to the current state
   of 20 just adds the interface.
Attachment #702149 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/c525391efd0d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Comment on attachment 702149 [details] [diff] [review]
bug 830396 - add back nsIDOMCSSValueList

Approving for uplift given add-on compat. We're not concerned about the UUID change, given the fact that FF20 is still on Aurora.
Attachment #702149 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.