Port |Bug 827303 - Firefox core and crypto services components assume services/sync is built|

RESOLVED FIXED in seamonkey2.18

Status

--
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.18

SeaMonkey Tracking Flags

(seamonkey2.17 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 701869 [details] [diff] [review]
patch [Checkin: Comments 3 and 5]

The package-manifest.in changes made in bug 827303 need to be ported in order to have Sync fully functional again. The base bug already landed on Aurora, too.

I haven't tested the patch yet, but other than putting the entries where they belong in the alphabet it's a straight port.

Hartmut, you reportedly saw an issue with reopening closed tabs with builds you created from current trunk code. This is probably due to this bug. Please check whether the attached patch fixes it for you.
Attachment #701869 - Flags: review?(neil)
Attachment #701869 - Flags: approval-comm-aurora?

Comment 1

6 years ago
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #0)

> Hartmut, you reportedly saw an issue with reopening closed tabs with builds
> you created from current trunk code. This is probably due to this bug.
> Please check whether the attached patch fixes it for you.

Yes, my new build contains your patch and the issue is gone.

Comment 2

6 years ago
Comment on attachment 701869 [details] [diff] [review]
patch [Checkin: Comments 3 and 5]

I see both of these in my objdir, that's good enough for me.
Attachment #701869 - Flags: review?(neil) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 701869 [details] [diff] [review]
patch [Checkin: Comments 3 and 5]

http://hg.mozilla.org/comm-central/rev/bc0de6d8ef78
Attachment #701869 - Attachment description: patch → patch [Checkin: Comment 3]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-seamonkey2.18: affected → ---
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.18

Comment 4

6 years ago
Comment on attachment 701869 [details] [diff] [review]
patch [Checkin: Comments 3 and 5]

a=me for comm-aurora
Attachment #701869 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 5

6 years ago
Comment on attachment 701869 [details] [diff] [review]
patch [Checkin: Comments 3 and 5]

http://hg.mozilla.org/releases/comm-aurora/rev/1f3b4fd70db8
Attachment #701869 - Attachment description: patch [Checkin: Comment 3] → patch [Checkin: Comments 3 and 5]
(Assignee)

Updated

6 years ago
status-seamonkey2.17: affected → fixed
tracking-seamonkey2.17: ? → ---
You need to log in before you can comment on or make changes to this bug.