Last Comment Bug 830450 - Clicking on the purchase button for app with an HTML description does nothing
: Clicking on the purchase button for app with an HTML description does nothing
Status: VERIFIED FIXED
u=patron p=1
:
Product: Marketplace
Classification: Server Software
Component: Payments/Refunds (show other bugs)
: 1.0
: All All
: P1 critical (vote)
: 2013-01-17
Assigned To: Kumar McMillan [:kumar] (needinfo all the things)
:
Mentors:
: 831078 (view as bug list)
Depends on: 831524
Blocks: marketplace-payments
  Show dependency treegraph
 
Reported: 2013-01-14 11:55 PST by krupa raj[:krupa]
Modified: 2013-01-29 16:57 PST (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description krupa raj[:krupa] 2013-01-14 11:55:26 PST
steps to reproduce:
1. Navigate to https://marketplace-dev.allizom.org/app/krupas-paid-app-1/ on your unagi phone or desktop b2g build
2. Click on the purchase button

observed behavior:
Button status changes to "purchasing" for a second and reverts to back to app price. Payments flow is not triggered.

JS error:
Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/js/mkt/consumer-min.js?build=aef9d41:16 in anonymous: Error code:"
Comment 1 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-15 17:16:48 PST
to clarify, this only happens when purchasing the app in the STR! Checking it out now...
Comment 2 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-15 17:37:35 PST
the server is producing the right JWT. Checking to see where the client messes it up...
Comment 3 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-16 15:17:28 PST
bug 831524 is the culprit. I'll land a workaround soon in Marketplace where we shorten the JWT until it is fixed.
Comment 4 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-17 09:45:19 PST
narrowed this down to an issue with atob() choking on encoded HTML
Comment 5 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-18 15:54:30 PST
We're stripping HTML from app descriptions now which should avoid running into the atob() issue. https://github.com/mozilla/zamboni/commit/5393f4b6f76a93635400500c755bfa5d0037d031
Comment 6 Victor Carciu 2013-01-21 08:38:27 PST
Verified as fixed : http://screencast.com/t/JNyRHo87Skt
Comment 7 Wil Clouser [:clouserw] 2013-01-29 16:57:48 PST
*** Bug 831078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.