OTA update should remove update.mar file from sdcard

VERIFIED FIXED in Firefox 21

Status

Firefox OS
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dhylands, Assigned: dhylands)

Tracking

unspecified
B2G C4 (2jan on)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: [triage:1/16])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Currently, if the OTA update places the update.mar file on the sdcard, then it doesn't get removed.

I'm not aware of any issues caused by this, other than it consumes space on the sdcard.
(Assignee)

Comment 1

5 years ago
It seems that if the update.mar file is corrupt, then this can prevent further updates from occurring.
blocking-b2g: --- → tef?
(Assignee)

Updated

5 years ago
Blocks: 830126
(Assignee)

Comment 2

5 years ago
Created attachment 702133 [details] [diff] [review]
Remove update.mar from sdcard when finished (or when starting a new download)

Now removes stale update.mar file from sdcard at the start of a new download, and after an update was applied.
Attachment #702133 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

5 years ago
Assignee: nobody → dhylands
Attachment #702133 - Flags: review?(robert.bugzilla) → review+
blocking-b2g: tef? → tef+
(Assignee)

Comment 3

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=20180251f907
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c7572ad0ef03
(Assignee)

Updated

5 years ago
Duplicate of this bug: 830126
Whiteboard: [triage:1/16]

Comment 6

5 years ago
Hey Dave, can you not dupe older bugs to newer bugs?  that is inconsiderate to original bug filers as they view their bug becomes useless.   (you duped my bug that was filed as 830126 :( )  

that said, i'm still seeing this problem on today's build, when attempting to update from 20130115070201 -> 20130116070204; and watching it fail.

Logcat:
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC Creating Downloader
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC Creating Downloader
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC UpdateService:_downloadUpdate
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC UpdateService:_downloadUpdate
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC readStringFromFile - file doesn't exist: /data/local/updates/0/update.status
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC readStringFromFile - file doesn't exist: /data/local/updates/0/update.status
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC Downloader:_selectPatch - found existing patch with state: null
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC Downloader:_selectPatch - found existing patch with state: null
01-16 10:41:20.335: I/Gecko(108): *** AUS:SVC Downloader:_selectPatch - failed to apply complete patch!
01-16 10:41:20.335: E/GeckoConsole(108): AUS:SVC Downloader:_selectPatch - failed to apply complete patch!
01-16 10:41:20.365: D/memalloc(108): /dev/pmem: Allocated buffer base:0x4b200000 size:81920 offset:8273920 fd:144
01-16 10:41:20.365: D/memalloc(360): /dev/pmem: Mapped buffer base:0x44100000 size:8355840 offset:8273920 fd:28
01-16 10:41:20.395: I/Gecko(108): *** AUS:SVC Downloader:downloadUpdate - no patch to download
01-16 10:41:20.395: E/GeckoConsole(108): AUS:SVC Downloader:downloadUpdate - no patch to download
01-16 10:41:20.395: I/Gecko(108): *** AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
01-16 10:41:20.395: E/GeckoConsole(108): AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
01-16 10:41:20.405: I/Gecko(108): UpdatePrompt: Error downloading update Firefox 18.0: 0
01-16 10:41:20.405: I/Gecko(108): UpdatePrompt: Update error, state: download-failed, errorCode: 0
01-16 10:41:20.415: I/Gecko(108): UpdatePrompt: Setting gecko.updateStatus: The integrity of the update could not be verified
01-16 10:41:20.415: I/GeckoDump(108): XXX FIXME : Got a mozContentEvent: update-available-result
(Assignee)

Comment 7

5 years ago
(In reply to Tony Chung [:tchung] from comment #6)
> Hey Dave, can you not dupe older bugs to newer bugs?  that is inconsiderate
> to original bug filers as they view their bug becomes useless.   (you duped
> my bug that was filed as 830126 :( )  

So how would you like it handled then? The patch is in this bug, which is currently on inbound. I expect it will land on b2g18 once it lands on central.

> that said, i'm still seeing this problem on today's build, when attempting
> to update from 20130115070201 -> 20130116070204; and watching it fail.

> 01-16 10:41:20.415: I/Gecko(108): UpdatePrompt: Setting gecko.updateStatus:
> The integrity of the update could not be verified

So that looks like the same problem, and should be addressed once this lands.

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c7572ad0ef03
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
(In reply to Dave Hylands [:dhylands] from comment #7)
> (In reply to Tony Chung [:tchung] from comment #6)
> > Hey Dave, can you not dupe older bugs to newer bugs?  that is inconsiderate
> > to original bug filers as they view their bug becomes useless.   (you duped
> > my bug that was filed as 830126 :( )  
> 
> So how would you like it handled then? The patch is in this bug, which is
> currently on inbound. I expect it will land on b2g18 once it lands on
> central.

It's okay Dave, im just giving a headsup for next time.  Thanks for understanding.

> 
> > that said, i'm still seeing this problem on today's build, when attempting
> > to update from 20130115070201 -> 20130116070204; and watching it fail.
> 
> > 01-16 10:41:20.415: I/Gecko(108): UpdatePrompt: Setting gecko.updateStatus:
> > The integrity of the update could not be verified
> 
> So that looks like the same problem, and should be addressed once this lands.

cool, thanks for verifying.  happy to reproduce if you need more information.
(Assignee)

Comment 10

5 years ago
(In reply to Tony Chung [:tchung] from comment #9)
> (In reply to Dave Hylands [:dhylands] from comment #7)
> > (In reply to Tony Chung [:tchung] from comment #6)
> > > Hey Dave, can you not dupe older bugs to newer bugs?  that is inconsiderate
> > > to original bug filers as they view their bug becomes useless.   (you duped
> > > my bug that was filed as 830126 :( )  
> > 
> > So how would you like it handled then? The patch is in this bug, which is
> > currently on inbound. I expect it will land on b2g18 once it lands on
> > central.
> 
> It's okay Dave, im just giving a headsup for next time.  Thanks for
> understanding.

No problem. I normally would have dup'd the other way, but the patch and everything was all done before the dup was discovered.
(Assignee)

Comment 11

5 years ago
If you have adb access, you should be able to recover by doing:

adb shell rm /sdcard/updates/0/update.mar

and then doing a "Check Now" in the settings app (under Device Information). Preferrably from someplace that you get good wifi.
https://hg.mozilla.org/releases/mozilla-b2g18/rev/2103501b2fd1
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)
Duplicate of this bug: 831209
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed

Comment 15

5 years ago
Issue is verified fixed on:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/98354c0298ab
Gaia: edaca00b1eb7534120b6255db5d5200fb1d86d65   
build: 20130219070200
kernel date: Dec 5
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829068
You need to log in before you can comment on or make changes to this bug.