Closed Bug 830519 Opened 7 years ago Closed 7 years ago

Remove force-finish-parsing code from SVGDocumentWrapper::OnStopRequest

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 704059

People

(Reporter: dholbert, Unassigned)

References

Details

This chunk of code:
https://mxr.mozilla.org/mozilla-central/source/image/src/SVGDocumentWrapper.cpp?rev=50f4d34efeac&mark=264-270#254
in SVGDocumentWrapper::OnStopRequest is an ugly hack, to make us synchronously finish parsing an SVG document so that we'll be ready to draw* as soon as we return from that function.

Now that bug 505385 is resolved, I think we can drop that code & let the parser finish on its own schedule. (pending some work that seth's doing to make VectorImage benefit from bug 505385's changes)
Heh, I did this in my patch for 704509. =)
Excellent! Sorry for bug-spam; duping.
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: 704059
Resolution: --- → DUPLICATE
Duplicate of bug: 704059
You need to log in before you can comment on or make changes to this bug.