Closed Bug 83057 Opened 19 years ago Closed 19 years ago

Mozilla should duplicate content when opening new Navigator windows

Categories

(SeaMonkey :: General, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 18808

People

(Reporter: oded, Assigned: asa)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9) Gecko/20010505
BuildID:    20010528

When a new Navigator window is created, its content should be based on the
content of the window from which the command ("New Navigator Window") was
initiated, instead of loading the default homepage. The default homepage can be
easily loaded using the Home button. However, to duplicate the content from the
old window to the new one, the user has to copy the URL from the old window and
paste it into the new one, hoping no information was passed using Post and that
there are no other limits over reloading the page. This forking behavior can be
observed in Internet Explorer.

Reproducible: Always
Steps to Reproduce:
1. Visit the URL mentioned above.
2. Choose "New Navigator Window" under the File menu.


Actual Results:  Mozilla created a new Navigator window and loaded the default
homepage.

Expected Results:  Mozilla could duplicate the content of the originating window
(the one in which you chose "New Navigator Window") into the new window, along
with history information (for the Back and Forward buttons, etc.)
dup

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.