Starting Firefox with -private-window flag shows console error

RESOLVED FIXED in Firefox 20

Status

()

Firefox
Private Browsing
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: Ehsan)

Tracking

Trunk
Firefox 21
All
Windows 7
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

1) Open Firefox
2) Pin it to the taskbar
3) Close Firefox
4) Right-click the icon and choose "New private window"

You'll see an error in the console saying:

"Warning: unrecognized command line flag -private-window"
http://mxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserContentHandler.js#814

(Funnily, it's an error that says it's a warning.)

Updated

6 years ago
Blocks: 463027
(Assignee)

Comment 1

6 years ago
Created attachment 702555 [details] [diff] [review]
Consume the -private-window command line argument in per-window PB builds

In global PB builds, we handled this flag inside the service.  Now that the service
does not exist any more, this gets left unhandled.
(Assignee)

Updated

6 years ago
Attachment #702555 - Flags: review?(dolske)
(Assignee)

Updated

6 years ago
Assignee: nobody → ehsan
Attachment #702555 - Flags: review?(dolske) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 702555 [details] [diff] [review]
Consume the -private-window command line argument in per-window PB builds

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Not sure
User impact if declined: See comment 0
Testing completed (on m-c, etc.): Locally
Risk to taking this patch (and alternatives if risky): Minimal risk
String or UUID changes made by this patch: none.
Attachment #702555 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 4

6 years ago
Backed out to see if this has broken Marionette (but I think it is not at fault):

https://hg.mozilla.org/integration/mozilla-inbound/rev/2b9b4a3a835f
(Assignee)

Comment 5

6 years ago
Turns out that handleFlag returns bool not int.  Rookie mistake!

Relanded: https://hg.mozilla.org/integration/mozilla-inbound/rev/5087e184f8ad
https://hg.mozilla.org/mozilla-central/rev/5087e184f8ad
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21

Updated

6 years ago
Attachment #702555 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e84c4fb705fd
status-firefox20: --- → fixed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed in Firefox 20 beta 1 (buildID: 20130220104816) using STR from comment 0.
status-firefox20: fixed → verified

Comment 9

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130415 Firefox/23.0

I couldn't verify on Latest Nightly(Build ID:20130415030812), because after step 4 from STR, "New private window" button does not exist. There are just "Nightly" and "Unpin this program from taskbar" buttons.
(Assignee)

Comment 10

5 years ago
(In reply to Mitza from comment #9)
> Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130415 Firefox/23.0
> 
> I couldn't verify on Latest Nightly(Build ID:20130415030812), because after
> step 4 from STR, "New private window" button does not exist. There are just
> "Nightly" and "Unpin this program from taskbar" buttons.

What if you run Firefox once again and then close it?

Comment 11

5 years ago
I tried to run Firefox several times and the same result.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130428 Firefox/23.0 (Build ID: 20130428031010)

I have the same issue as Mitza: can't reproduce step 4, the "New private window" button does not appear; only the "Nightly" and "Unpin this program from taskbar" buttons appear.
You need to log in before you can comment on or make changes to this bug.