Page start playing sound, even with Firefox for Android in the background.

RESOLVED DUPLICATE of bug 809558

Status

()

RESOLVED DUPLICATE of bug 809558
6 years ago
2 years ago

People

(Reporter: hub, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When I open this page (of sponsored content) on The Atlantic, there is a sound that start playing, even if I have gone back to the twitter client. 

http://freze.it/talscientology

(apologize for the content - Safe For Work though - this what was linked to me, the original page might behave differently)

It doesn't happen on the desktop (I am Flash less as well)

Also in both case I'm over wifi.

Expected:

-the content should NEVER play back or even auto-load. After all, I might be on an expensive data plan
-even less, the content should STOP playing when the browser is not in the front.
(Reporter)

Comment 1

6 years ago
It also does it with that URL

http://www.theatlantic.com/misc/notice/
This is also reproducible in any desktop browser using the Fennec UA and disabling plugins.

Brightcove, the media content provider for The Atlantic and Freze It has enabled `autoStart` on the media-player they serve (passed as a parameter) to our user-agent. Firefox honors the auto-play they serve.
(Reporter)

Comment 3

6 years ago
We shouldn't honouring it on mobile because the connection is expensive.

(I also believe we shouldn't be enabling it on desktop and making it click to play)
I don't think there's any great way to do this without breaking the web for content that you WANT to play in the background. Sites are notified when they're put into the background and can pause on their own if they want. But even in this case there's a good use case for listening to the story in the background while you do something else in the foreground.

We've talked a little about reversing that. Sites could force things to NOT Pause if they want. My thought there has always been to force sites to call preventDefault() on visibilityChange events? We'd have to push a change like that into the spec. I'll fire a message there about it and see what happens.

Alternatively, maybe we could disable autoplay entirely on mobile? You could certainly write an addon for that, but it seems likely to make things break in some cases as well. i.e. I don't want to make webapps even bigger second class citizens.
(Reporter)

Comment 5

6 years ago
It is the default behaviour of iOS. And believe it or not I think it is the one that make the most sense. Website that push music and video to autoplay are BAD BAD BAD - even more on a connection that cost you money like cell phone. Even youtube on the desktop, but apparently they behave well on the mobile site but not auto-loading NOR auto-playing.

Worst of all of the thing is in the background.

In that case it started playing when I had moved away from the browser. That's even worse, it was a WTF moment.
(In reply to Hub Figuiere [:hub] from comment #5)
> It is the default behaviour of iOS. And believe it or not I think it is the
> one that make the most sense. Website that push music and video to autoplay
> are BAD BAD BAD - even more on a connection that cost you money like cell
> phone. Even youtube on the desktop, but apparently they behave well on the
> mobile site but not auto-loading NOR auto-playing.
> 
> Worst of all of the thing is in the background.

That would break Grooveshark HTML5 Mobile where I load up a variety of playlists and sometimes use their radio-service, and that would make me a sad panda :(
This is not iOS multitasking is a core feature of the OS.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809558
(Reporter)

Comment 9

6 years ago
I'm not sure I agree with the dupe resolution. We should NOT pre-load or auto-play videos. Period.
The HTML spec says otherwise http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#attr-media-autoplay there is an about config pref media.autoplay.enabled if you don't want this behaivor.
You need to log in before you can comment on or make changes to this bug.