Last Comment Bug 830765 - Multi-second hang during CollectNewLoadedModules
: Multi-second hang during CollectNewLoadedModules
Status: RESOLVED FIXED
[Snappy:P2]
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla21
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on:
Blocks: 524944
  Show dependency treegraph
 
Reported: 2013-01-15 07:08 PST by Vladan Djeric (:vladan)
Modified: 2013-01-26 10:22 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Remove the unneeded code (6.55 KB, patch)
2013-01-15 09:56 PST, :Ehsan Akhgari (busy, don't ask for review please)
jonas: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
Details | Diff | Review

Description Vladan Djeric (:vladan) 2013-01-15 07:08:37 PST
I noticed a 5 second main-thread hang with the following stack:

NtWaitForSingleObject (in wntdll.pdb)
RtlpDeCommitFreeBlock (in wntdll.pdb)
LdrQueryModuleInfoLocalLoaderLock (in wntdll.pdb)
RtlQueryProcessModuleInformation (in wntdll.pdb)
RtlQueryProcessDebugInformation (in wntdll.pdb)
ThpCreateRawSnap (in wkernel32.pdb)
CreateToolhelp32Snapshot (in wkernel32.pdb)
CollectNewLoadedModules (in xul.pdb)
nsAppShell::ProcessNextNativeEvent(bool) (in xul.pdb)
nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal *,bool,unsigned int) (in xul.pdb)
nsThread::ProcessNextEvent(bool,bool *) (in xul.pdb)
mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) (in xul.pdb)
MessageLoop::RunHandler() (in xul.pdb)
MessageLoop::Run() (in xul.pdb)
nsBaseAppShell::Run() (in xul.pdb)
nsAppShell::Run() (in xul.pdb)
nsAppStartup::Run() (in xul.pdb)
XREMain::XRE_mainRun() (in xul.pdb)
XREMain::XRE_main(int,char * * const,nsXREAppData const *) (in xul.pdb)
XRE_main (in xul.pdb)
do_main (in firefox.pdb)
wmain (in firefox.pdb)
__tmainCRTStartup (in firefox.pdb)
BaseThreadInitThunk (in wkernel32.pdb)
__RtlUserThreadStart (in wntdll.pdb)
_RtlUserThreadStart (in wntdll.pdb)

This stack is also a frequent chrome-hang. Can we make the CreateToolhelp32Snapshot call off the main thread?
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2013-01-15 09:56:06 PST
Created attachment 702393 [details] [diff] [review]
Remove the unneeded code
Comment 2 Jonas Sicking (:sicking) 2013-01-17 22:51:24 PST
Comment on attachment 702393 [details] [diff] [review]
Remove the unneeded code

Review of attachment 702393 [details] [diff] [review]:
-----------------------------------------------------------------

Yes! I don't believe we ever had use for this code. Definitely should go.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2013-01-21 12:57:52 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/97e4a7b942cd
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2013-01-22 10:01:37 PST
https://hg.mozilla.org/mozilla-central/rev/97e4a7b942cd
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2013-01-24 11:10:20 PST
Comment on attachment 702393 [details] [diff] [review]
Remove the unneeded code

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 524944, sort of.  This was debugging code landed there and never taken out.
User impact if declined: This seems to be one of big chrome hang items that Vladan has been seeing.  As this is pretty much risk free, I think it would be nice to take it on branches.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): this is just removing unused debugging code.  I'll say risk free.
String or UUID changes made by this patch: none.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2013-01-25 15:43:28 PST
Comment on attachment 702393 [details] [diff] [review]
Remove the unneeded code

Let's go with uplifting this to Aurora but even though it may be low risk, I think it's too late to take this on Beta and we'll just have to wait for it.
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2013-01-26 10:22:37 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/88daa2beccb3

Note You need to log in before you can comment on or make changes to this bug.