Last Comment Bug 830767 - we should implement a new about:mozilla text for B2G
: we should implement a new about:mozilla text for B2G
Status: RESOLVED FIXED
:
Product: Firefox OS
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: B2G C4 (2jan on)
Assigned To: Julien Wajsberg [:julienw]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 07:13 PST by Julien Wajsberg [:julienw]
Modified: 2015-03-13 08:21 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-
affected
affected
fixed
+
fixed


Attachments
screenshot (38.96 KB, image/png)
2013-01-15 07:13 PST, Julien Wajsberg [:julienw]
no flags Details
go forth and multiply, little foxes (1.80 KB, patch)
2013-01-17 12:14 PST, Johnathan Nightingale [:johnath]
dtownsend: review+
l10n: review-
Details | Diff | Review
about:mozilla - html changes part (1.84 KB, patch)
2013-01-18 01:54 PST, Julien Wajsberg [:julienw]
gerv: review+
Details | Diff | Review
go forth and multiply, little foxes, v2 (1.88 KB, patch)
2013-01-22 06:34 PST, Julien Wajsberg [:julienw]
l10n: review+
overholt: approval‑mozilla‑b2g18+
Details | Diff | Review
about:mozilla - html changes part, v2 (1.85 KB, patch)
2013-01-22 06:36 PST, Julien Wajsberg [:julienw]
l10n: review+
overholt: approval‑mozilla‑b2g18+
Details | Diff | Review

Description Julien Wajsberg [:julienw] 2013-01-15 07:13:18 PST
Created attachment 702302 [details]
screenshot

For each key event for Mozilla corresponds a new about:mozilla text.

We should definitely have a new one for B2G.

Attached is a screenshot of the current one (the same as in Firefox Desktop actually).
Comment 1 Julien Wajsberg [:julienw] 2013-01-15 07:13:50 PST
Nominating because I wouldn't ship without this.
Comment 2 Josh Carpenter [:jcarpenter] 2013-01-15 09:12:46 PST
Matej, do you know who the right person to write this is?
Comment 3 Jonas Sicking (:sicking) PTO Until July 5th 2013-01-15 09:14:47 PST
cc'ing some oldtimers who might remember who wrote the text for previous versions.
Comment 4 Matej Novak [:matej] 2013-01-15 09:35:01 PST
Would be happy to help with this, but I'm pretty slammed right now. Would also be happy for someone else to grab it. CCing John as well for his thoughts.
Comment 5 Gervase Markham [:gerv] 2013-01-15 09:42:18 PST
Wow. Great minds... I sent an email round to a small group of Mozillians about this only yesterday! Here it is:

The Book of Mozilla quote was last updated in 2008, referring to events which happened in 2004 - the launch of Firefox 1.0. The launch of B2G 1.0 seems like another pivotal moment in project history, and time to update it again.

...

Here is my opening proposal:


"New enemies arose to oppose the beast and its followers. And there was
a great gathering from every corner of the earth. As the enemies of the
beast grew great, the beast grew small - but therein was the secret of
its victory."

from The Book Of Mozilla, X:XX


The X:XX date would either be the B2G 1.0 release date, if such a thing actually exists, or perhaps the date of our launch event at Mobile World Congress ('a great gathering from every corner of the earth').

I've attempted to keep the right tone. We would need to put key words in a larger font, as it is currently (and perhaps "smaller" in a smaller font ;-). Alterations, total rewrites or alternative suggestions are very welcome. http://en.wikipedia.org/wiki/Book_of_mozilla is a reference for the previous verses.

We should keep the same verse in all products rather than ship a special one for B2G.

Gerv
Comment 6 Julien Wajsberg [:julienw] 2013-01-15 10:10:47 PST
I love Gerv's proposition.
Comment 7 Johnathan Nightingale [:johnath] 2013-01-15 10:20:39 PST
Beltzner and I wrote the last rev, if I remember correctly, and Neil Deakin wrote the one before that. I agree that it's worth a new one (though I don't also agree that it isn't a blocker. :)

As for the text itself, it's very possible to overthink these things, but that's also sort of tradition. The current rev references everything going on at the time, and we should do so, too. In the spirit of overthought, then:

- I would avoid "enemies" per se, and instead keep the Mammon references flowing. If Apple and Google are the Microsofts of the day, maybe we talk about the "twin children of Mammon"
- I'd use January 15 as the reference date. Everyone in the project has felt the impact of that date. It doesn't have much external significance, but that's even better, really. "1:15" is too early in the book for it to show up, but "15:1" seems appropriate - it antedates all prior entries, and being the first verse of a new chapter is pretty appropriate.
- I'd include a reference to rapid release (new since the last incarnation)
- I'd also like to reference Android (also new) or more generically the idea of Firefox becoming multiple things

Riffing on Gerv's, then, perhaps:

"The twins of Mammon quarreled. Their warring besieged the world and it was plunged into a NEW DARKNESS, and The Beast abhorred the darkness. And The Beast began to move more SWIFTLY, and it grew more powerful. And as it grew, its followers were amazed, and The Beast became two beasts, and then three, and then more. And The Beasts brought FIRE to the darkness."

from The Book of Mozilla, 15:1
Comment 8 Julien Wajsberg [:julienw] 2013-01-15 10:31:20 PST
I like the sentence "the beast grews small" in Gerv's proposition. It's a nice oxymoron that says well that we're targeting small devices in contrary to esp. Apple.
Comment 9 Johnathan Nightingale [:johnath] 2013-01-15 10:56:21 PST
(In reply to Julien Wajsberg [:julienw] from comment #8)
> I like the sentence "the beast grews small" in Gerv's proposition. It's a
> nice oxymoron that says well that we're targeting small devices in contrary
> to esp. Apple.

What about suggesting that we play across the size spectrum with a modification to the second last sentence, like:

"The twins of Mammon quarreled. Their warring besieged the world and it was plunged into a NEW DARKNESS, and The Beast abhorred the darkness. And The Beast began to move more SWIFTLY, and it grew more powerful. And as it grew, its followers were amazed, and The Beast became two beasts, and then three, and then more beasts all of different sizes. And The Beasts brought FIRE to the darkness."

from The Book of Mozilla, 15:1
Comment 10 Julien Wajsberg [:julienw] 2013-01-15 11:09:11 PST
I still like the two words "grew small" being next to each other. I also like the rythm in "grew great" / "grew small", that's poetry :)

Your text is good too, we should be able to mix both (but not me, my english skills prevents this ;) ).
Comment 11 Gervase Markham [:gerv] 2013-01-16 00:56:39 PST
I agree about the overthinking. 

- Agree about January 15th.
- Switching the date around would be inconsistent with all previous entries, but I do see your logic.
- "beast" historically has had a small 'b'.
- quarrelled has two 'l's ;-)

Riffing some more, with cadence tweaks:

"The TWINS of Mammon quarrelled. Their warring plunged the world into a NEW DARKNESS, and the beast abhorred the darkness. So it began to move SWIFTLY, and grew more powerful, and went forth and multiplied. And the many beasts banished the darkness with FIRE."

from The Book of Mozilla, 15:1

Gerv
Comment 12 Dan Mosedale (:dmose) 2013-01-16 13:58:18 PST
I like the last one.  One thought: perhaps s/FIRE/LIGHT.  To me, it would give it more of a leadership/showing-the-way connotation.

-- the author of 12:10 for Netscape 1.1
Comment 13 Gervase Markham [:gerv] 2013-01-16 14:21:10 PST
"...with FIRELIGHT"?

Gerv
Comment 14 Johnathan Nightingale [:johnath] 2013-01-16 14:38:40 PST
We aren't "many" yet, but this feels good. How about:

"The TWINS of Mammon quarrelled. Their warring plunged the world into a NEW DARKNESS, and the beast abhorred the darkness. So it began to move SWIFTLY, and grew more powerful, and went forth and multiplied. And the beasts brought FIRE and LIGHT to the darkness."

from The Book of Mozilla, 15:1
Comment 15 Johnathan Nightingale [:johnath] 2013-01-16 15:05:32 PST
(by delicious coincidence, this will also be coming out right around MoFo's 15 year anniversary, making the 15:1 reference multi-layer. The current text included the "10th Edition" text to refer to MoFo's 10th.)
Comment 16 Dan Mosedale (:dmose) 2013-01-16 17:19:18 PST
Nice!  johnath++
Comment 17 Gervase Markham [:gerv] 2013-01-17 01:13:15 PST
Comment 14 looks good to me.

Gerv
Comment 18 Johnathan Nightingale [:johnath] 2013-01-17 12:14:29 PST
Created attachment 703489 [details] [diff] [review]
go forth and multiply, little foxes

I take Gerv's review as granted, but let's get a module owner review, too. I haven't built this, on account of how my build environment doesn't like me right now.
Comment 19 Gervase Markham [:gerv] 2013-01-17 12:51:03 PST
You missed an <em>:

<em>LIGHT</em>

r=gerv.

Gerv
Comment 20 Dave Townsend [:mossop] 2013-01-17 12:54:07 PST
Comment on attachment 703489 [details] [diff] [review]
go forth and multiply, little foxes

I wouldn't dare question anything here!
Comment 21 Julien Wajsberg [:julienw] 2013-01-17 14:06:21 PST
IIRC we used to add some new HTML/CSS stuff when we do a new about:config page.

So maybe we can do that here too.

I suggest :
- using a <section> around the 2 <p>
- text-rendering: optimizeLegibility
- some transition-on-hover stuff
- a subtle radial gradient for background

It would be awesome to add some JS API too but I'm not sure which one. accelerometer/gyroscope API which could trigger a 3d transform ?

Any other idea ?
Comment 22 Julien Wajsberg [:julienw] 2013-01-17 14:11:39 PST
Also, I believe this will need to be sent to translators so I'm adding 'late-l10n' and CC Pascal and Pike.
Comment 23 Julien Wajsberg [:julienw] 2013-01-17 14:21:38 PST
I'll be able to propose something tomorrow if nobody do that before.
Comment 24 Axel Hecht [:Pike] 2013-01-17 14:25:48 PST
Technical detour: I don't think we need to localize this immediately, thus un-flagging late-l10n. If we were, we'd have to do to so on the l10n release repos, which no localizer is actually supposed to mess with.
Comment 25 Julien Wajsberg [:julienw] 2013-01-18 01:54:07 PST
Created attachment 703823 [details] [diff] [review]
about:mozilla - html changes part

I kept it simple:
- added meta charset
- use the HTML5 doctype
- removed the xml prologue (but I add to keep the html ns attribute because we're in an xhtml file because of translations)
- added a radial gradient background
- added 'optimizeLegibility'
- min-height is necessary because otherwise the background-image doesn't cover the whole viewport in a big browser window
- added a section

I tried adding a meta viewport too but it looks actually nicer on the B2G device without this meta. So I left it like that.

Who could review this ?
Comment 26 Julien Wajsberg [:julienw] 2013-01-20 13:16:34 PST
Maybe gerv ?
Comment 27 Gervase Markham [:gerv] 2013-01-21 01:44:12 PST
Comment on attachment 703823 [details] [diff] [review]
about:mozilla - html changes part

r=gerv - seems fine to me. The radial gradient is subtle enough that it makes it pop a bit more without divorcing the look from the historical one, so I like it.

optimizeLegibility does nothing for me on Linux, and I haven't tested on mobile.

Gerv
Comment 28 Julien Wajsberg [:julienw] 2013-01-21 06:33:06 PST
Comment on attachment 703489 [details] [diff] [review]
go forth and multiply, little foxes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: no new about:mozilla for B2G
Testing completed: yes, on a FFOS device
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: yes
Comment 29 Julien Wajsberg [:julienw] 2013-01-21 06:33:16 PST
Comment on attachment 703823 [details] [diff] [review]
about:mozilla - html changes part

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: about:config's markup and CSS will be boring
Testing completed: yes, on a FFOS device
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: no
Comment 30 Axel Hecht [:Pike] 2013-01-21 06:40:18 PST
Comment on attachment 703489 [details] [diff] [review]
go forth and multiply, little foxes

Review of attachment 703489 [details] [diff] [review]:
-----------------------------------------------------------------

r-, we can't change strings without changing their ID.
Comment 31 Julien Wajsberg [:julienw] 2013-01-22 03:13:33 PST
Comment on attachment 703489 [details] [diff] [review]
go forth and multiply, little foxes

Johnathan, do you want to change this yourself or may I step in and update your patch with l10n's requirement ?

I'll probably try to keep it separated in 2 patches to keep the authors.
Comment 32 Gervase Markham [:gerv] 2013-01-22 05:34:25 PST
Julien: I'm sure johnath would appreciate you updating the patches.

Gerv
Comment 33 Julien Wajsberg [:julienw] 2013-01-22 06:34:53 PST
Created attachment 704868 [details] [diff] [review]
go forth and multiply, little foxes, v2

was r=dtownsend already

asking for r=pike
Comment 34 Julien Wajsberg [:julienw] 2013-01-22 06:36:44 PST
Created attachment 704869 [details] [diff] [review]
about:mozilla - html changes part, v2

was r=gerv already

ask for Pike's review for l10n
Comment 35 Julien Wajsberg [:julienw] 2013-01-22 06:37:33 PST
I tested both together on a FFOS device and it works for me.
Comment 36 Axel Hecht [:Pike] 2013-01-22 06:45:31 PST
Comment on attachment 704869 [details] [diff] [review]
about:mozilla - html changes part, v2

Review of attachment 704869 [details] [diff] [review]:
-----------------------------------------------------------------

I like using the book version for the entities, nicely semantic. r=me.
Comment 37 Julien Wajsberg [:julienw] 2013-01-22 06:49:47 PST
Comment on attachment 704868 [details] [diff] [review]
go forth and multiply, little foxes, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: no new about:mozilla for B2G
Testing completed: yes, on a FFOS device
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: yes
Comment 38 Julien Wajsberg [:julienw] 2013-01-22 06:49:55 PST
Comment on attachment 704869 [details] [diff] [review]
about:mozilla - html changes part, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: no new about:mozilla for B2G
Testing completed: yes, on a FFOS device
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: yes
Comment 39 Julien Wajsberg [:julienw] 2013-01-22 06:50:15 PST
Comment on attachment 704869 [details] [diff] [review]
about:mozilla - html changes part, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: no new about:mozilla for B2G
Testing completed: yes, on a FFOS device
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: yes
Comment 43 HeadJam 2015-03-13 08:21:02 PDT Comment hidden (spam)

Note You need to log in before you can comment on or make changes to this bug.