Closed Bug 830835 Opened 8 years ago Closed 8 years ago

update a app, cancel the download, check for update => does not send a downloadavailable event

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed)

RESOLVED FIXED
mozilla21
blocking-b2g tef+
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- fixed

People

(Reporter: julienw, Assigned: fabrice)

References

Details

Attachments

(1 file)

This bug has two implications:
* the update notification toaster is not appearing
* calling checkForUpdates from the app (for example https://github.com/julienw/self-updating-packaged-app) will not return that an update is available

However we correctly have the update notification in the notification panel because the system app keeps the information.

I think this may be fixed by sending a "downloadavailable" event even when we get a 304 status from the server, if app.downloadAvailable is true.
Needs more info to make blocking call.

Does this always reproduce? On a specific testcase? On stubs only?

Can you give a minddump of info here?
Flags: needinfo?(felash)
This always reproduce from an app which controls its own update mechanism, like the stubs yes.

I asked a nomination because it seems to be a safe patch. However I agree this is a minor case.
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> This always reproduce from an app which controls its own update mechanism,
> like the stubs yes.
> 
> I asked a nomination because it seems to be a safe patch. However I agree
> this is a minor case.

Okay. We do have do stubs for v1 for preloads though, which actually does make me think this blocks.

Screwing up a download once and then not being able to recover for a preload would probably not make Rick happy.
That should block.
Attached patch patchSplinter Review
Assignee: nobody → fabrice
Attachment #703663 - Flags: review?(felash)
Comment on attachment 703663 [details] [diff] [review]
patch

tested and approved !

works for me, thanks
Attachment #703663 - Flags: review?(felash) → review+
blocking-b2g: tef? → tef+
Comment on attachment 703663 [details] [diff] [review]
patch

[Triage Comment]
Attachment #703663 - Flags: approval-mozilla-b2g18+
https://hg.mozilla.org/releases/mozilla-b2g18/rev/0420ae287619
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Target Milestone: --- → mozilla21
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.