Closed Bug 830842 Opened 7 years ago Closed 7 years ago

Clear Downloads button should appear only for Downloads View

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: mak, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file)

Not sure if this regressed or what, but Show All Bookmarks should hide it.
Attached patch patchSplinter Review
The current view setter calls _setupView only if the view changes. That doesn't happen for the initial view
Assignee: mak77 → mano
Attachment #702421 - Flags: review?(mak77)
Comment on attachment 702421 [details] [diff] [review]
patch

Review of attachment 702421 [details] [diff] [review]:
-----------------------------------------------------------------

thanks
Attachment #702421 - Flags: review?(mak77) → review+
Comment on attachment 702421 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Download panel feature (regression from bug 827405)
User impact if declined: broken ui
Testing completed (on m-c, etc.): tbd.
Risk to taking this patch (and alternatives if risky): trivial change, limited to the Library.
String or UUID changes made by this patch: none.
Attachment #702421 - Flags: approval-mozilla-aurora?
Attachment #702421 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/69c937105d32
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified as fixed on the latest Nightly and Aurora - the Clear Downloads button appears now only for the Downloads View.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130128 Firefox/21.0 Build ID:20130128030943
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130128 Firefox/20.0 Build ID:20130128042018	

Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130128 Firefox/21.0 Build ID:20130128030943
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130123 Firefox/20.0 Build ID:20130128042018

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130128 Firefox/21.0	Build ID:20130128030943
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130128 Firefox/20.0	Build ID:20130128042018
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.