Closed Bug 830848 Opened 8 years ago Closed 8 years ago

Improve Mozillians UX

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 766760

People

(Reporter: hoosteeno, Unassigned)

References

Details

(Whiteboard: [ux])

Tracker for bugs related to UX improvement in Q1/Q2 2012.
(2012->2013 in above comment.)
Depends on: 657071
Whiteboard: [ux]
Depends on: 766760
We have numerous other bugs for this particular activity, including bug 766760 which is well underway. I'm closing as a dupe.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766760
Verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.