UX input on visual design for HTML <input type=range> on Android

RESOLVED DUPLICATE of bug 763671

Status

()

defect
RESOLVED DUPLICATE of bug 763671
7 years ago
6 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

Trunk
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

HTML's <input type="range"> is generally implemented as a slider, and that's still what Chrome for Android does even on mobile devices. Cwiiis suggested that I should get some UX input for our implementation nevertheless.

Spec:
http://www.whatwg.org/specs/web-apps/current-work/multipage/states-of-the-type-attribute.html#range-state-%28type=range%29

Live examples:
http://www.html5tutorial.info/html5-range.php
Version: unspecified → Trunk
I have been thinking about this a little bit. Part of me wants us to create a "keyboard-like input panel" across the bottom of the screen with a native Android slider. That way we can make sure the user is able to touch and drag the handle.
That said, I would not hold up work in range for a native "keyboard". We can test out using in-content UI as a start.
mozilla-inbound now has all the patches that should be needed in order to allow range to be styled.

Ian, Wes, should this be marked as a duplicate of bug 763671, and have the design worked on there? Or should this be kept open?
Flags: needinfo?(ibarlow)
For the record, this work has been going on in bug 763671.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763671
Assignee: ibarlow → nobody
Flags: needinfo?(ibarlow)
You need to log in before you can comment on or make changes to this bug.