Stop button doesn't stop downloads for plugins (like Flash animations)

RESOLVED DUPLICATE of bug 11875

Status

()

RESOLVED DUPLICATE of bug 11875
18 years ago
5 years ago

People

(Reporter: MatthiasMann, Assigned: serhunt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

When I visit a page with a larger flash animation (on a lower bandwidth
connection so that the flash needs a few seconds or more to load) and I hit the
stop button the flash animation is still loading. It should stop loading.

The same should be true when clicking on a link that loads a new page in the
current window (see bug 78521).

Reproducible: Always
Steps to Reproduce:
1. Visit a page with a large flash animation (like
http://www.derbauer.de/BIII_TRAILER.htm)
2. hit the stop button while the flash is still loading

Actual Results:  It's still loading

Expected Results:  It should stop loading

Comment 1

18 years ago
->plugins?
Component: Networking → Plug-ins

Updated

18 years ago
Blocks: 11875
Can anyone confirm if the stop button should do that, because the plugin is not
part of the browser, if you want to stop a flash anim you just right click on
the flash playing and select fordward.
Note that IE works the same way as Mozilla.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010709
Shockwave Flash 5.0 r41
(Reporter)

Comment 3

18 years ago
It should not stop the animation - it should stop the all downloads from the
current page (including downloads made by a plugin)

Comment 4

18 years ago
this works in ns4.x at least on win32, the stop button seems to be disabled in
mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Av, I think that this is yours.  
Assignee: neeti → av

Comment 6

18 years ago
4.x and IE both do this and it's a dup of bug 11875. It's a very useful feature
to  halt all network streams for all plugins with one command.

*** This bug has been marked as a duplicate of 11875 ***
No longer blocks: 11875
Status: NEW → RESOLVED
Last Resolved: 18 years ago
OS: Windows 98 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.