Composer: bold paragraph after pressing return in heading

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mapson12, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15
Build ID: 20130105222032

Steps to reproduce:

Composer settings: 
- Use CSS styles 
- Pressing return creates new paragraph

Press return at the end of a heading.



Actual results:

The next paragraph will have bold formatting. 


Expected results:

The next paragraph should be a normal paragraph without any style.

Workaround: after pressing return, press up and down arrow key, then the bold formatting is gone.

Comment 1

6 years ago
Can't reproduce, provide full steps how you get this (ie 1) Open blank Composer page, 2)...)
Flags: needinfo?(mapson12)
(Reporter)

Comment 2

6 years ago
1. Open blank Composer page
2. Make sure that in the settings "Composer / Use CSS-styles instead of HTML Elements" is set.
3. Type some text
4. click on the format dropdown and select "heading 1" (line is now formatted as heading 1)
5. press return
6. type some text

-> the text is bold.

This behavior occurs only when the "use CSS styles" setting is active.
Flags: needinfo?(mapson12)

Comment 3

6 years ago
Confirming on Trunk
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 SeaMonkey/2.18a1
Build identifier: 20130110003008
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Version: SeaMonkey 2.15 Branch → Trunk

Comment 4

6 years ago
This is probably a duplicate of:
Bug 833610 - Using cr to break a list forgets the default font
Or perhaps:
Bug 832025 - Major regression in HTML editing rules in CSS mode related to TypeInState

Comment 5

5 years ago
Can no longer reproduce on trunk, closing as WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.