If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Marketplace loading and performance issues

RESOLVED FIXED

Status

Marketplace
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Launching marketplace causes the following things-

a) A gray screen (browser placeholder) loads and after a while, a blank screen loads and then the marketplace homepage loads.
b) marketplace generally takes a long time to load
c) Page load is super slow on marketplace-dev.

I have seen this on mozilla-G and mozilla guest. We should look into optimizing marketplace performance.

I will try to get the actual load times for the above mentioned issues.
Cvan:  Krupa says you have ideas for this.  What do you have in mind?

Comment 2

5 years ago
Created attachment 703033 [details]
Resource size report for 2013-01-16

Here's an analysis of the current network load for an initial mobile Marketplace pageload. We should file bugs for the low hanging fruit in here.
(In reply to Wil Clouser [:clouserw] from comment #1)
> Cvan:  Krupa says you have ideas for this.  What do you have in mind?

jinja2js, etc. Basta has all kind of ideas. Slimming down our CSS/JS and reducing our image assets is something we're actively doing (the past few days), and both Potch and Basta are actively measuring our page sizes.

Comment 4

5 years ago
Filed https://github.com/mozilla/browserid/issues/2946 for communication_iframe.js
Duplicate of this bug: 819479
We have a splash screen now while loading and Fireplace is solving a lot of performance problems.  This bug doesn't have specific things to fix so I'm going to close it.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.