Closed Bug 831021 Opened 7 years ago Closed 7 years ago

Toolbar curve jumps 4px on tab slide animation

Categories

(Firefox for Android :: Theme and Visual Design, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: shorlander, Assigned: sriram)

References

Details

Attachments

(2 files)

Attached image Curve Overlay
The curve on the toolbar during the slide animation doesn't line up with the curve in the default state. This creates a noticeable jump at the end of the animation.

The offset appears to be about 4px.
/summon Sriram
Duplicate of this bug: 840987
Assignee: nobody → sriram
Attached patch PatchSplinter Review
Corrected the marginRight so that the curves match.
Attachment #714097 - Flags: review?(mark.finkle)
Attachment #714097 - Flags: review?(mark.finkle) → review+
Comment on attachment 714097 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Some regression somewhere.
User impact if declined: Users will sharp eyes will find that we are overlapping when animation ends.
Testing completed (on m-c, etc.): Landed in m-i on 02/14.
Risk to taking this patch (and alternatives if risky): Very less. Just margin values changed.
String or UUID changes made by this patch: None.
Attachment #714097 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e1d92d4bf209
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Attachment #714097 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.