Last Comment Bug 83103 - Add support for Outlook express to the addressbook
: Add support for Outlook express to the addressbook
Status: RESOLVED FIXED
[br]
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla0.9.4
Assigned To: Cyrille Moureaux
: Ninoschka Baca
:
Mentors:
Depends on: 78933
Blocks: 83100
  Show dependency treegraph
 
Reported: 2001-05-29 07:47 PDT by Cuchulainn
Modified: 2007-10-14 03:09 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
This patch to be applied after patch #78933. (124.41 KB, patch)
2001-05-31 02:57 PDT, John Marmion
no flags Details | Diff | Splinter Review
update against latest patch for #78933 (124.00 KB, patch)
2001-06-08 10:44 PDT, John Marmion
no flags Details | Diff | Splinter Review
Keep patch up-to-date against changes to 78933 (124.99 KB, patch)
2001-07-16 09:17 PDT, John Marmion
no flags Details | Diff | Splinter Review
Keep patch up-to-date against #78933 plus address possible MAPI Threading issue (129.12 KB, patch)
2001-07-23 10:26 PDT, John Marmion
no flags Details | Diff | Splinter Review
Keep patch up-to-date against 'sr' changes to 78933 (145.54 KB, patch)
2001-07-31 09:50 PDT, John Marmion
no flags Details | Diff | Splinter Review
Apply syntactical changes requested by sr of 78933 to this patch (150.52 KB, patch)
2001-08-02 02:14 PDT, John Marmion
no flags Details | Diff | Splinter Review
Keep in sync with head and support #83023 Query Totals (139.30 KB, patch)
2001-08-08 08:25 PDT, John Marmion
no flags Details | Diff | Splinter Review

Description User image Cuchulainn 2001-05-29 07:47:57 PDT
78933 adds support for Outlook. We also need to add support for Outlook express.
In order to do this we will have to support the WAB API as well as the
MAPI interface.
Comment 1 User image John Marmion 2001-05-31 02:57:50 PDT
Created attachment 36631 [details] [diff] [review]
This patch to be applied after patch #78933.
Comment 2 User image Cuchulainn 2001-05-31 03:07:29 PDT
Cyrille is modifying code to support WAB so this bug has been reassigned.
Comment 3 User image John Marmion 2001-05-31 03:30:01 PDT
This patch must be applied on top of patch #78933. This patch will enable
support for both Outlook Express(WAB) and Outlook(MAPI). To activate Outlook
Express(OE) you simply need to edit the preferences file prefs.js:

Add 4 entries:

user_pref("ldap_2.servers.OE.description", "Outlook Express");
user_pref("ldap_2.servers.OE.dirType, 3);
user_pref("ldap_2.servers.OE.position", x);
user_pref("ldap_2.servers.OE.uri", "aboutlookdirectory://oe/");

Note:

we choose OE to represent Outlook Express. This name must be unique. The dirType
must be set to 3. 'x' is set to the next available position and the 'uri' is set
as above where 'oe' will distinguish Outlook Express from 'op' which will
respresent Outlook.

Thus to enable Outlook you also need to add 4 corresponding entries:

user_pref("ldap_2.servers.OP.description", "Outlook");
user_pref("ldap_2.servers.OP.dirType", 3);
user_pref("ldap_2.servers.OP.position", x);
user_pref("ldap_2.servers.OP.uri", "aboutloookdirectory://op/");

To activate Outlook in Mozilla, Outlook must be set as the default mailer. This
is consistent with the way the Mozilla Import facility works. The WAB or Outlook
Express will be activated regardless and to activate both, Outlook must be set
as the default mailer.

To Sumarise:

-The WAB interface will return the contents of the OE address book WHATEVER the
default mail client is.
-The MAPI interface will return the contents of the Outlook address book ONLY if
Outlook is defined as the default mail client.

The contents of the Outlook address book are NOT necessarily the same as the OE
address book. They only are, if a specific option has been selected in OE,
instructing it to 'share' (i.e. override) the contents of its address book with
those of Outlook's. The WAB interface displays the correct address book
depending on this setting.

We will provide an experimental build at http://abzilla.mozdev.com
Comment 4 User image John Marmion 2001-06-08 10:44:58 PDT
Created attachment 37671 [details] [diff] [review]
update against latest patch for #78933
Comment 5 User image Keyser Sose 2001-06-18 19:59:56 PDT
*** Bug 57658 has been marked as a duplicate of this bug. ***
Comment 6 User image John Marmion 2001-06-19 01:21:15 PDT
The last comment marking this as a duplicate of #57658 misses the central point
of this bug. This fix is not about importing Outlook Express into Mozilla but
rather it makes available Outlook Express Address Books to Mozilla dynamically.
Comment 7 User image John Marmion 2001-07-16 09:17:47 PDT
Created attachment 42394 [details] [diff] [review]
Keep patch up-to-date against changes to 78933
Comment 8 User image John Marmion 2001-07-23 10:26:58 PDT
Created attachment 43219 [details] [diff] [review]
Keep patch up-to-date against #78933 plus address possible MAPI Threading issue
Comment 9 User image Blake Ross 2001-07-25 01:28:33 PDT
Missed the 0.9.3 train.
Comment 10 User image John Marmion 2001-07-31 09:50:11 PDT
Created attachment 44114 [details] [diff] [review]
Keep patch up-to-date against 'sr' changes to 78933
Comment 11 User image John Marmion 2001-07-31 09:53:30 PDT
The 'sr' changes requested for #78933 have resulted in this latest patch. This
patch is now up-to-date against #78933 and also any issues raised during the
'sr' of #78933 have been applied to this patch.
Comment 12 User image chuang 2001-07-31 15:54:35 PDT
r=chuang.  I am not familiar with WAB,  but it looks good to me.
Comment 13 User image John Marmion 2001-08-02 02:14:00 PDT
Created attachment 44362 [details] [diff] [review]
Apply syntactical changes requested by sr of 78933 to this patch
Comment 14 User image John Marmion 2001-08-02 02:19:50 PDT
I have just updated the patch against the requested syntactical changes
requested by the sr of #78933. These changes are now located in #93092.
Typically the changes required a code change e.g.

if(aCard == nsnull)....
to
if(!aCard)..........
Comment 15 User image John Marmion 2001-08-08 08:25:12 PDT
Created attachment 45071 [details] [diff] [review]
Keep in sync with head and support #83023 Query Totals
Comment 16 User image Scott MacGregor 2001-08-09 10:13:23 PDT
sr=mscott. My only comment is that you might want to wrap alot of the printfs
you added with #ifdef DEBUG flags. I know someone (cls?) is creating bugs on
people who are using printfs that will show up in release builds. 
Comment 17 User image John Marmion 2001-08-10 05:51:41 PDT
Good stuff. The PRINTF() are defined as NS_LOG_PRINTF() which I believe only
gets enabled in DEBUG builds as defined in nslog.h. But I will contact cls to
verify  this before applying for a landing. I assume cls is cls@seawood.org.
Comment 18 User image John Marmion 2001-08-10 06:40:04 PDT
I have got the foloiwng reply from cls....

> Hi,
> 
> We received the following sr for:
> 
> http://bugzilla.mozilla.org/show_bug.cgi?id=83103
> 
> with the proviso that we clean up the PRINTF()s. Typically we 
> have used the following:
> 
> #include "nslog.h"
> 
> #define PRINTF NS_LOG_PRINTF(nsWabLog)
> 
> 
> ....PRINTF("Cannot load library.\n");
> 
> 
> I wanted to clarify that this is OK. I would appreciate a reply.

Looks fine to me.

- cls
Comment 19 User image Dan Mosedale (:dmose) 2001-08-10 13:35:00 PDT
Code checked in.
Comment 20 User image fenella 2001-08-14 16:45:43 PDT
Developer, please advise QA how to verify this bug.
Comment 21 User image Cyrille.Moureaux 2001-08-15 01:24:39 PDT
To verify the bug, add to the preferences the four lines described in one of the
first comments, only with the uri equal to "moz-aboutlookdirectory://oe/".
Provided Outlook Express is installed on the machine, and regardless of its
configuration (default mailer or not, sharing address book with Outlook or not), 
you should see additional address books available which names start with OE.
These address books should support standard address book features
(addition/deletion/edition of cards/mailing lists).
Comment 22 User image John Marmion 2001-08-15 04:04:26 PDT
In addition to Cyrille's comments about how to test this code, the code will not
be activated until the corresponding UI patch is landed:
http://bugzilla.mozilla.org/show_bug.cgi?id=83100.

It is hoped that a patch and experimental builds for the 83100  bug will be
produced soon which would allow this code to be tested. In the meantime,
manually editing the preferences file is the only means to activate this code.
Let us know if you need any help with this.

Comment 23 User image fenella 2001-08-20 11:32:46 PDT
Thanks. I'll wait for bug 83100 to be fixed.

Note You need to log in before you can comment on or make changes to this bug.