Closed Bug 83111 Opened 19 years ago Closed 15 years ago

Mouse-over acts differently if over a fixed position div vs a relative positioned div

Categories

(Core :: User events and focus handling, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 267842
Future

People

(Reporter: attinasi, Unassigned)

References

()

Details

This was sent to me via newsgroup/email:

The page concerned has a "position:fixed" navigation DIV. I have a
hidden sub-menu which pops up when the mouse hovers over the relevant
link.
The problem is moving the mouse over the popped-up sub-menu. Unless I
move the mouse over *very slowly*, the sub-menu disappears. This does
not happen if "position:absolute" is used instead.
Is it a mistake I'm making or is it a bug?
I have put up two pages demonstrating the problem:-

http://www.alexanderworks.org/menu%20tests/fixed.html
http://www.alexanderworks.org/menu%20tests/absolute.html

Please let me know if I'm posting to the wrong newsgroup.
Thanks,
Philip Pawley
http://www.alexanderworks.org/
QA contact updated
QA Contact: gerardok → madhur
Target Milestone: --- → mozilla0.9.8
What I'm seeing is a flickering at the div's border region to the right, when
slowly hovering over it. Minor bug, imo. 
Win98, 2001122103.
The problem is *not* the flickering. The problem is that the div usually disappears altogether if one attempts to move the mouse over it in order to click a link in the sub-menu it contains. 

This makes it is *impossible* to use this method of creating pop-up menus. It will effectively prevent any web-site that uses this kind of JavaScript menu from using a fixed-positioned navigation bar.

What's the point of having fixed positioning at all if it can't be used? If that's the best that can be managed, it would be better to admit that fixed positioning doesn't actually work and scrap it for now. (It's not as if this is the only major problem with fixed positioning in Mozilla, either). 

On the other hand, *if* Mozilla could be the first browser in which fixed positioning really did work, that would something to crow about. So come on, folks, I'm rooting for you!
Repeated comment. (Sorry about the lack of line-breaks above). 

The problem is *not* the flickering. The problem is that the div usually
disappears altogether if one attempts to move the mouse over it and click
a link in the sub-menu it contains. 

This makes it is *impossible* to use this method of creating pop-up menus.
It will effectively prevent any web-site that uses this kind of JavaScript
menu from using a fixed-positioned navigation bar.

What's the point of having fixed positioning at all if it can't be used?
If that's the best that can be managed, it would be better to admit that
fixed positioning doesn't actually work and scrap it for now. (It's not as
if this is the only major problem with fixed positioning in Mozilla, either). 

On the other hand, *if* Mozilla could be the first browser in which fixed
positioning really did work, that would something to crow about.
So come on, folks, I'm rooting for you! 
Philip, what I wanted to say is that to me the issue initially described in the
bug report doesn't exist anymore. Do you see the problem in recent builds?
Yes, Dimitrios, I check the bug with each new build as it comes out. It is there
just as much in 0.9.7 as was to begin with. If one is *very* careful, one can take
the mouse on to the pop-up, but, most times, the pop-up just vanishes as soon as
the attempt is made.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Target Milestone: mozilla0.9.9 → mozilla1.1
QA Contact: madhur → rakeshmishra
QA Contact: rakeshmishra → trix
.
Assignee: joki → saari
QA Contact: trix → ian
retargeting
Target Milestone: mozilla1.1alpha → Future
Confirming that this bug still exists with the latest nightly.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:) Gecko/20040302
Assignee: saari → events
it is probably the same as bug 267842, which has a nice testcase.
duping to a bug with testcase..

*** This bug has been marked as a duplicate of 267842 ***
No longer blocks: 267842
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.