Closed Bug 831432 Opened 7 years ago Closed 7 years ago

Downloads button has no text in Text button mode

Categories

(Firefox :: Downloads Panel, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: sdrocking, Assigned: mak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 3 obsolete files)

No description provided.
not sure if it's worth spending time on this considered bug 573329.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I wonder if just adding the label would fix this without causing regressions in the anchor
Attached patch patch v1.0 (obsolete) — Splinter Review
this is the less invasive patch I may think of.
The only defect is that the arrow still points the icon, not the text, in full mode. Though fixing that would be more invasive and regression-prone.

I tested this only on Windows and afaict seems to work fine.
Attachment #703053 - Flags: feedback?(mconley)
Comment on attachment 703053 [details] [diff] [review]
patch v1.0

Your approach is fine as a stopgap until we remove those two other modes.

Seems to work fine in Ubuntu. Works well in OSX too - my only slight complaint is that when we're in full mode, the text label is misaligned with the labels of the other buttons.
Attachment #703053 - Flags: feedback?(mconley) → feedback+
Blocks: 831772
(In reply to Mike Conley (:mconley) from comment #4)
> Seems to work fine in Ubuntu. Works well in OSX too - my only slight
> complaint is that when we're in full mode, the text label is misaligned with
> the labels of the other buttons.

only on OSX?
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attached image Label and icon on OSX (obsolete) —
I believe so. Here's OSX.
ah probably my margin: 0 rule is wrong, I couldn't find where the margins were defined so that rule was too wide.
Attached image Label and icon on Ubuntu (obsolete) —
And here we are on Ubuntu.  Bookmarks and Social are a bit derpy, but that's outside the scope of this bug.
Attached patch patch v1.1Splinter Review
The style is taken from toolbarbutton.css + browser.css
Attachment #703053 - Attachment is obsolete: true
Attachment #703336 - Attachment is obsolete: true
Attachment #703337 - Attachment is obsolete: true
Attachment #706772 - Flags: review?(mconley)
Comment on attachment 706772 [details] [diff] [review]
patch v1.1

Review of attachment 706772 [details] [diff] [review]:
-----------------------------------------------------------------

This does the job - tested on all three platforms. Code looks good too. Ship it!
Attachment #706772 - Flags: review?(mconley) → review+
Comment on attachment 706772 [details] [diff] [review]
patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: text and full toolbar modes won't work properly
Testing completed (on m-c, etc.): m-i, local
Risk to taking this patch (and alternatives if risky): limited to the feature and those 2 modes, css-only changes
String or UUID changes made by this patch: none
Attachment #706772 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b4be6e1db784
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #706772 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130213 Firefox/21.0 (20130213031137)
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130212 Firefox/20.0 (20130212042017)

Verified as fixed on the latest Nightly and Aurora - in text mode, the downloads button is properly displayed (with text).

Verified on Windows 7, Ubuntu 12.10 and Mac OS X 10.7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.