Gaia SMS app does not show first message in new conversation

RESOLVED DUPLICATE of bug 830335

Status

Firefox OS
Gaia::SMS
--
blocker
RESOLVED DUPLICATE of bug 830335
5 years ago
5 years ago

People

(Reporter: Alhad Purnapatre, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 702986 [details]
Screenshots of good and bad case

This seems to have changed or broken recently. Gaia SMS application no longer shows the first message in a new conversation.

Steps to reproduce:

1. In SMS application, start a new SMS conversation (either on a fresh build with no SMS messages or delete all SMS conversations) by composing a text message to any phone number.

2. Hit Send

Expected result:

The SMS being sent is shown in a conversation view with a spinwheel next to it (that indicates sending in progress), and the spinwheel goes away after the SMS is acknowledged and just the message shows.

Actual result:

The conversation window is completely blank. SMS does get sent successfully and if we go back to messages list, it is seen. If we come back into conversation window from messages list, message is now correctly seen.

Please see good.png and bad.png from attached zip for the good case and bad case respectively.
(Reporter)

Updated

5 years ago
Blocks: 808607
blocking-b2g: --- → tef?
Is this bug 830335 by chance?  Are you sending the text to a local number (5555555) or an internationalized one (+15555555)?
(Reporter)

Comment 2

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #1)
> Is this bug 830335 by chance?  Are you sending the text to a local number
> (5555555) or an internationalized one (+15555555)?

Oh yeah, looks like same issue as 830335. One of the comments in that bug mention my exact scenario. I'll mark as dup, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830335
blocking-b2g: tef? → -
Marking tef+ as it's duplicating a tef+ bug 830335.
blocking-b2g: - → tef+
You need to log in before you can comment on or make changes to this bug.