unable to share mozilla profiles with dual boot win98 and win2000

RESOLVED WONTFIX

Status

Core Graveyard
Profile: BackEnd
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: mozilla, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010527
BuildID:    2001052720

i have a system with both win 2000 & 98se running
i install my nightly in a directory mozilla when i start mozilla under 2000 i'm
unable to use mozilla to navigate under 98 
(no response to anything typed into the url bar) and the otherway
also when starting mozilla in 98 (after first running it under 2000) i first get
a blank page and an empty url bar
clicking the home button and following links however does work
mozilla under 98 and 2000 uses a different profile for each os

Reproducible: Always
Steps to Reproduce:
1.have a dual boot system (2000 - 98)
2.start mozilla under 2000 with a profile for 2000(all ok)
3.reboot to 98
4.start mozilla under 98 with it's 98 profile
5.get a blank page and empty url bar
6.click home button to load homepage (ok)
7.type a new url into the urlbar and press enter : no response

Actual Results:  under 2000 all ok
under 98 no homepage loaded on startup
does not react to url's into the url bar

Expected Results:  same functionality under both os's from the same directory

under both os's mozilla is installed in j:\mozilla\
both os' have their profile in j:\mozilla\profiles\[98-2000]

Comment 1

17 years ago
try creating a new profile for win98, does that help?
(Reporter)

Comment 2

17 years ago
nope no luck
only deleting the mozilla dir and reinstalling a  new nightly under any of the 
os's makes it work again

Comment 3

17 years ago
hmm, not sure where this belongs

Comment 4

17 years ago
Trying Profiles...
Assignee: asa → ccarlen
Status: UNCONFIRMED → NEW
Component: Browser-General → Profile Manager BackEnd
Ever confirmed: true
QA Contact: doronr → gbush
Summary: unable to share mozilla with dual boot windows → unable to share mozilla profiles with dual boot windows

Comment 5

17 years ago
Is this a duplicate of bug 58647 (Use same preferences, bookmarks, cache, mail
folders on dual boot system)?
Summary: unable to share mozilla profiles with dual boot windows → unable to share mozilla profiles with dual boot win98 and win2000
(Assignee)

Comment 6

17 years ago
No, it's quite different from that one - This is on the same system (more or
less), with the same file path format. Bug 58647 is about sharing between a
Windows/Linux dual boot system and should be an RFE. What's described here is a
bug because it should work. 
(Assignee)

Comment 7

17 years ago
> both os' have their profile in j:\mozilla\profiles\[98-2000]

No, it's not going to work. While the profiles are in a common directory, the
profile registries are not. Still, what's described (blank page and empty url
bar) shouldn't happen though. Do you move the profile dirs around by hand?
(Reporter)

Comment 8

17 years ago
no the profile's have been created by the wizard

so for mozilla under 98 : 
-profile : j:\mozilla\profiles\98
-bin dir : j:\mozilla\bin
-os dir : c:\windows

under 2000:
-profile : j:\mozilla\profiles\2000
-bin dir : j:\mozilla\bin
-os dir : e:\winnt

Comment 9

17 years ago
I can partly confirm this. I share profiles between WIn2000 and Win NT clients 
through a LAN and Samba, with NO problems. But there are still some differences 
when sharing profiles between Win and Unix-based Mozillas. E.g. a newsgroup 
server in the WIn-created profile is not displayed as well when accessing the 
same profile from a Unix/Linux Mozilla.

(Tested on rv:0.9.3+) Gecko/20010831). 
Should I file some of these errors separately?
(Assignee)

Comment 10

17 years ago
Something needs to happen here with being able to customize where the profile
registry is kept. Then these two systems could share the same profile registry
and profiles.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 11

17 years ago
*** Bug 93875 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 58647
(Assignee)

Comment 12

17 years ago
-> future
Target Milestone: mozilla0.9.9 → Future

Comment 13

16 years ago
Seems to me that the easiest way to solve this issue is to fix one of the
various bugs about allowing the user to specify the profile directory.
Then the user can install in 98 as usual and set the profile directory to
wherever, after that he can fire it up on 2000 and point it at the win98 profile
folder.

Comment 14

16 years ago
When mozilla comes up with a blank screen under 98, the following errors appear
in the javascript console... Hopefully these might help someone?

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/urlbarBindings.xml#urlbar.updatePref() :: updatePref
:: line 2"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.addProgressListener()
:: addProgressListener :: line 4"  data: no]

Comment 15

16 years ago
Simlar Issue but not quite the same,

On a Dual boot system - Win98/2k
Install Mozilla into Win98 boot d:\Mozilla
Picks up Netscape 4.7 profiles OK from D:\Netscape.47
Boot and Install Mozilla 1.3a into Windows 2000
Cannot pick up and use the current profile in d:\Mozilla\Profiles
No option to check path at import stage
Software insists on looking at C drive
This is probably by design I guess??

Many people have multi-partitions due to everythign wanting to install to C:\
I don't want internet profiles and caches from IE, Netscape and Mozilla
filling up C: and I'd like my profiles to go to D: and be able to choose.

Suggestion for redesign:
At import trigger event ...
1) Show current Profiles directory (currently now shown)
2) Permit navigation to alternate profiles folder
3) If a current Mozilla profile is found in an alternate folder
then prompt to use this one.

Currently unable to use Mozilla when in Win2000 boot unless profile is
recreated from scratch (including addtional POP3 sessions added).

Hope this helps!

Thanks for a great product. :)

Mark
(Assignee)

Comment 16

16 years ago
> On a Dual boot system - Win98/2k

If both systems in a dual boot are the same flavor of OS (Windows, *nix), there
is a workaround. This will not work on a Win/Linux dual boot because of the
different file path formats between the two.

For Win98/2k dual boot, try this:
(1) Create a profile on one of the systems. When creating it, use "Choose
Folder" in the profile wizard to specify a location for the profile which will
be accessable from either system.
(2) Reboot into the other system.
(3) Create a profile on the 2nd system. Again, use "Choose Folder" to select the
location. If the profile created in (1) was in:
C:\SharedMozProfile\profileName\xxxxxxxx.slt, you need to choose
C:\SharedMozProfile\ with "Choose Folder" and make sure that the name of the 2nd
 profile is "profileName.'

This will make the 2nd profile use the same directory as the 1st, without
creating new data files. Notice this is a very tedious, obscure way of importing
a profile. There are bugs on that to make it easier.

Updated

12 years ago
QA Contact: agracebush → profile-manager-backend

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.