[meta] GC: Get Generational barriers in IonMonkey

RESOLVED DUPLICATE of bug 851057

Status

()

RESOLVED DUPLICATE of bug 851057
6 years ago
6 years ago

People

(Reporter: terrence, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
We need to generate code to update the store buffer whenever we update a gc pointer. This should look at sites that need incremental barriers and expend this to initializing writes (which incremental barriers don't care about). In JM this was the initprop and initelem opcodes, plus misc code in stubs.

The post barrier verifier will allow us to verify that we have caught all of the places that we need to update the store buffer.
(Reporter)

Updated

6 years ago
Depends on: 851057

Comment 1

6 years ago
Bug 851057 is done, only missing Bug 867815 – anything else to do here? 

Either way, I don't see a real difference between this bug and Bug 851057, thus the relation to bug 720522 (blocking bug 851057) is unclear – can somebody please clarify this?

Comment 2

6 years ago
(In reply to Florian Bender from comment #1)
>  (blocking bug 851057) 

I mean "blocked by bug 851057".
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851057
You need to log in before you can comment on or make changes to this bug.