If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsIPluginStreamListener2 should be removed

VERIFIED DUPLICATE of bug 115891

Status

()

Core
Plug-ins
P5
normal
VERIFIED DUPLICATE of bug 115891
17 years ago
15 years ago

People

(Reporter: Peter Lubczynski, Assigned: Peter Lubczynski)

Tracking

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
nsIPluginStreamListener2 was added because of bug 82415. It should be removed 
and the overloaded ODA should be worked into the existing interface like DougT 
suggests in bug 82415.
(Assignee)

Comment 1

17 years ago
Setting milesonte to mozilla0.9.2
Status: NEW → ASSIGNED
Keywords: nsbeta1
Priority: -- → P1
Target Milestone: --- → mozilla0.9.2
(Assignee)

Updated

17 years ago
Whiteboard: [no eta][d:3]
(Assignee)

Comment 2

17 years ago
it's clear this isn't going to make it, moveing to mozilla0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 3

17 years ago
peter, you did document that this interface is not public.  I really don't want 
to have to have this supported for the rest of mozilla's life.
(Assignee)

Comment 4

17 years ago
Doug, is this not good enough:
http://lxr.mozilla.org/seamonkey/source/modules/plugin/public/nsIPluginStreamListener2.h#22

Comment 5

17 years ago
I guess we will know when we remove that interface in 0.9.3 + and start getting 
hate mail... :-)
(Assignee)

Updated

17 years ago
Blocks: 88998

Updated

17 years ago
No longer blocks: 88998
(Assignee)

Updated

17 years ago
Blocks: 88998
(Assignee)

Comment 6

17 years ago
I won't get to this today--->mozilla0.9.4
Keywords: nsbeta1
Whiteboard: [no eta][d:3]
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Comment 7

16 years ago
Not as easy as I thought...but nobody is using byte ranges in the new API yet
anyway.
Priority: P1 → P5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla0.9.9

Comment 8

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla0.9.9 → mozilla1.0.1
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla0.9.9
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 9

16 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
(Assignee)

Comment 10

16 years ago
This has been fixed with bug 115891.

*** This bug has been marked as a duplicate of 115891 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 11

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.