Status

P5
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: asa, Unassigned)

Tracking

Details

(Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 status=verified)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 703476 [details]
UC-42 	 Stop navigation
(Reporter)

Updated

6 years ago
Priority: -- → P2
(Reporter)

Updated

6 years ago
Whiteboard: c=navigation_app_bar_and_autocomplete u= p= → c=navigation_app_bar_and_autocomplete u= p=0 feature=story status=for_testing
(Reporter)

Updated

6 years ago
Whiteboard: c=navigation_app_bar_and_autocomplete u= p=0 feature=story status=for_testing → c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=0 feature=story status=for_testing
(Reporter)

Updated

6 years ago
Priority: P2 → P5
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Summary: Stop navigation → Story – Stop navigation
(Reporter)

Updated

6 years ago
Whiteboard: c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=0 feature=story status=for_testing → c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 feature=story status=for_testing

Updated

6 years ago
Blocks: 839143
(Reporter)

Updated

6 years ago
Whiteboard: c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 feature=story status=for_testing → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 status=for_testing
(Reporter)

Comment 1

6 years ago
Tested 2013-02-12 Elm Nightly build from http://hg.mozilla.org/projects/elm/rev/aac6ba901fea

The stop button appears to work as expected.
Status: RESOLVED → VERIFIED
Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 status=for_testing → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 status=verified

Updated

6 years ago
Blocks: 841099
No longer blocks: 839143
(Reporter)

Updated

6 years ago
Summary: Story – Stop navigation → Story - Stop navigation
(Reporter)

Updated

6 years ago
Resolution: WORKSFORME → FIXED

Updated

6 years ago
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Re-verfied for it4 testing as per steps in Comment 1 and everything passes without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-03-27-03-10-35-mozilla-central/

Added the following extra steps:

- Ensured that the "Stop" button also works correctly when the App Bar is opened
Went through the "Story" for it5 testing and everything passes without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-15-03-08-12-mozilla-central/

- Went through the extra steps outlined in Comment 2
- Ensured the "Stop" works with multiple tabs opened
- Ensured the "Stop" works correctly while Firefox Metro is in Filled View
I was going to verify this for it7 but there is no "stop" button on the app bar.  I think this is by design.

Still, in desktop Firefox you can stop navigation by pressing "escape" and that does NOT currently work in Windows 8 Style Firefox.  Filed bug 875975.
Should there be a stop button?
Flags: needinfo?(asa)
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130702 Firefox/25.0
Build ID: 20130702110300
WFM.
Tested this for iteration 9 on latest nightly from
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/07/2013-07-02-11-03-00-mozilla-central/

I followed above user story and got expected result.
I will make the executive assumption there is no stop button by design and clear the request for Asa. ESC works as a stop control for loading the page, so this should be good.
Flags: needinfo?(asa)
(Reporter)

Comment 8

5 years ago
Sorry I'm late here. There is a stop button that resides inside of the addressbar text field in the same space as the reload button. Only one of those shows at a time. When a page is loading, the stop button is visible. When the page is not loading, the reload button is visible. Pressing stop while the page is loading should stop the page from loading.
WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-22-03-02-26-mozilla-central/

I followed user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130809030203
Built from http://hg.mozilla.org/mozilla-central/rev/e33c2011643e

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in user story and got expected result.
Went through the following "Story" for iteration #12 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-21-05-01-36-mozilla-central/

- Went through the original story from comment #0 without any issues
- Went through the test cases added in comment #3 without any issues
- Ensured that the "Stop" button is appearing correctly when the website is being loaded
- Ensured that pressing/tapping on "Stop" OR using "ESC" works without any issues
- Went through all of the above test cases using filled view without any issues
You need to log in before you can comment on or make changes to this bug.