Non-system apps from Marketplace and everything me scroll up whitespace until only whitepsace remains.

VERIFIED FIXED in Firefox 21

Status

Firefox OS
General
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Guillermo Huerta [Disabled MoCo account], Assigned: kentuckyfriedtakahe)

Tracking

({regression, smoketest})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: [shadow:jmuizelaar])

Attachments

(2 attachments)

Noticed this after updating to the latest build.  The Twitter app from Marketplace and the facebook app from Everything.me scroll up whitespace when you scroll down in them.  This can be scrolled down by scrolling back to the top, but no information below the whitespace is visible.
Actually I'm seeing this in the marketplace itself.  When the whitespace scrolls up it changes the touch mapping as well proportionally to the size of screen that remains visible.

Updated

5 years ago
Duplicate of this bug: 831875

Updated

5 years ago
Duplicate of this bug: 831892
Noming to block - smoketest regression. This prevents logging into the facebook app.
blocking-b2g: --- → tef?
Keywords: regression, smoketest

Updated

5 years ago
Component: Gaia → Gaia::Keyboard
QA Contact: wachen

Updated

5 years ago
Component: Gaia::Keyboard → General
QA Contact: wachen
Thought it was a keyboard bug, but after seeing the dupes I don't think it is.

Something blew up royally in the scrolling dept - Marketplace installed apps aren't even rendering post scrolling right now.
Flags: needinfo?(jones.chris.g)
Chris - Any ideas?

This seems like a recent regression.
Bug 811950 might be responsible.  Possibly bug 830256 which hasn't been uplifted yet.
Assignee: nobody → ajones
blocking-b2g: tef? → tef+
Flags: needinfo?(jones.chris.g)
Why are apps installed from the marketplace behaving so much differently than preinstalled apps?  Please don't tell me we're launching them as a window.open from the system app ...

Comment 9

5 years ago
Created attachment 703584 [details]
[B2G] Showing white space when scrolling upward.  White screen raises when scrolling up and lowers when scrolling downward

Issue also happens when trying to login to sync contacts.  Build 20130117070201
FWIW this did not happen with unagi_beta_20130114070200.zip (14-Jan-2013 08:08).
Bumping up to critical because this is making a bunch of apps/sites partially unusable.
Severity: normal → critical

Updated

5 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM

Comment 12

5 years ago
This is also happening with the HERE Maps app thats on the phone. 

Repro Steps
1. Click on top right hand icon
2. Click on route
3. Enter address/location in From and To location
4. click on the list button on the right hand side of screen
5.  Start scrolling up and view what happens to the screen/page

Build 20130117070201 Kernel Dec 5th
(In reply to Chris Jones [:cjones] [:warhammer] from comment #8)
> Why are apps installed from the marketplace behaving so much differently
> than preinstalled apps?  Please don't tell me we're launching them as a
> window.open from the system app ...

Hopefully not. There use the same regular mechanism. app.launch().
Duplicate of this bug: 832214
I am also seeing this on the Facebook integration... is this w/ bug 830256 ?  there's a patch that landed in inbound, but not on b2g 18.
I'm seeing this in the browser as well when clicking to create a new bug in landfill.bugzilla.org.  cc'ing ben on this bug so he's aware.

Updated

5 years ago
Duplicate of this bug: 831389

Updated

5 years ago
Duplicate of this bug: 832222

Updated

5 years ago
Duplicate of this bug: 832222
Bug 832222 has some screenshots.
Whiteboard: [shadow:jmuizelaar]
Anthony, Jeff, this is still a blocker, we think - any progress?
Created attachment 704700 [details] [diff] [review]
Remove extra scroll compensation code
Attachment #704700 - Attachment description: Bug 831973 - Remove extra scroll compensation code; r=roc → Remove extra scroll compensation code
Attachment #704700 - Flags: review?(roc)

Comment 23

5 years ago
Try run for 1e5bb1ff62c6 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=1e5bb1ff62c6
Results (out of 16 total builds):
    success: 15
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-1e5bb1ff62c6
Comment on attachment 704700 [details] [diff] [review]
Remove extra scroll compensation code

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 811950
User impact if declined: Everything broken except the browser
Testing completed: Tested marketplace.mozilla.org both hosted and in browser. Tested nytimes.com and nzherald.co.nz.
Risk to taking this patch (and alternatives if risky): May make other layer positioning bugs more obvious.
String or UUID changes made by this patch: None
Attachment #704700 - Flags: approval-mozilla-b2g18?
Aren't we able to land tef+ bugs automatically without approval?

Comment 26

5 years ago
Try run for 8092ef4f25f6 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=8092ef4f25f6
Results (out of 81 total builds):
    exception: 1
    success: 73
    warnings: 7
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-8092ef4f25f6
I ran into this scrolling issue with the Gasbuddy app.  Here's a video of my experience: http://people.mozilla.org/~jhopkins/bug831973/

Software: Boot2Gecko 1.0.0-prerelease, Last updated: 1/21/2013 2:08PM
Comment on attachment 704700 [details] [diff] [review]
Remove extra scroll compensation code

tef+ bugs don't need approval for landing on b2g18 so I'm clearing that request.

Johnny pointed out that this patch does have this oddity:

-+                                                 &treeTransform);
+                                                 &treeTransform);
Attachment #704700 - Flags: approval-mozilla-b2g18?

Updated

5 years ago
Duplicate of this bug: 833554

Updated

5 years ago
Duplicate of this bug: 833558
Duplicate of this bug: 833456
Two additional testcases not mentioned in the summary, and filed in duped bugs:

* Persona native login panel (bug 833554)
* Marketplace itself (bug 833558)
(In reply to Andrew Overholt [:overholt] from comment #29)
> -+                                                 &treeTransform);
> +                                                 &treeTransform);

The extra + was inadvertently added when rebasing bug 811950 https://hg.mozilla.org/releases/mozilla-b2g18/rev/d43f324b618b but is not significant.
Keywords: checkin-needed

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g18/rev/e3803e97aeff
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified on 1/23 build by testing out marketplace and persona flows - not seeing the white scrolling content issue now.
Status: RESOLVED → VERIFIED
(In reply to Jason Smith [:jsmith] from comment #39)
> Verified on 1/23 build by testing out marketplace and persona flows - not
> seeing the white scrolling content issue now.

Is there a link to a flashable image of 1/23 containing this fix that I may try? Or will it make it to a new beta (dogfooding) OTA update real soon? 

Thanks
dkl
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.