If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in mozilla::layers::PImageContainerChild::OnMessageReceived

RESOLVED DUPLICATE of bug 827833

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 827833
5 years ago
5 years ago

People

(Reporter: m1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [BTG-989])

Attachments

(1 attachment)

Created attachment 703698 [details]
decoded minidump of crash

Seen during stability test on AU 177.

STR
1. Start camcorder and take some videos
2. Goto 1

Top frames:
Crash reason:  SIGSEGV
Crash address: 0x0

Thread 8 (crashed)
 0  libxul.so!mozalloc_abort [mozalloc_abort.cpp : 30 + 0x4]
     r4 = 0x4364ac34    r5 = 0x00000000    r6 = 0xffffffff    r7 = 0x4364a848
     r8 = 0x40bf1301    r9 = 0x00000001   r10 = 0x4364a848    fp = 0x410e1052
     sp = 0x4364a830    lr = 0x410676e7    pc = 0x410676ea
    Found by: given as instruction pointer in context
 1  libxul.so!NS_DebugBreak_P [nsDebugImpl.cpp : 423 + 0x5]
     r4 = 0x4364ac34    r5 = 0x00000000    r6 = 0xffffffff    r7 = 0x4364a848
     r8 = 0x40bf1301    r9 = 0x00000001   r10 = 0x4364a848    fp = 0x410e1052
     sp = 0x4364a838    pc = 0x40bf10e9
    Found by: call frame info
 2  libxul.so!mozilla::layers::PImageContainerChild::FatalError [PImageContainerChild.cpp : 527 + 0x15]
     r4 = 0x00000007    r5 = 0x00000000    r6 = 0x4364ac78    r7 = 0x00160000
     r8 = 0x4364ad78    r9 = 0x43206e50   r10 = 0x00000000    fp = 0x00000001
     sp = 0x4364ac68    pc = 0x40b6da35
    Found by: call frame info
 3  libxul.so!mozilla::layers::PImageContainerChild::OnMessageReceived [PImageContainerChild.cpp : 383 + 0x7]
     r4 = 0x00000007    r5 = 0x00000000    r6 = 0x4364ac78    r7 = 0x00160000
     r8 = 0x4364ad78    r9 = 0x43206e50   r10 = 0x00000000    fp = 0x00000001
     sp = 0x4364ac78    pc = 0x40b6dfd5
    Found by: call frame info
This is/was bug 827833.  Let's hope this didn't have the fixes from bug 826829.
http://git.mozilla.org/?p=releases/gecko.git;a=shortlog;h=3ec4dc233e7258d5e8315e021cf4f35f876a1231

Appears not to have made it.  Whew!
(Reporter)

Comment 3

5 years ago
Ah, cool.  Fix for bug 827833 missed AU 177
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827833
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.