Closed Bug 832180 Opened 10 years ago Closed 9 years ago

Test failure "Unexpectedly found element ID: footer-right" in testToolbar/testStopReloadButtons.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

All
Windows 8
defect

Tracking

(firefox18 fixed, firefox19 fixed, firefox20 fixed, firefox21 fixed, firefox24 affected, firefox-esr17 fixed)

RESOLVED FIXED
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed
firefox24 --- affected
firefox-esr17 --- fixed

People

(Reporter: AndreeaMatei, Assigned: AndreeaMatei)

References

()

Details

(Whiteboard: [mozmill-test-failure] s=130204 u=failure c=toolbar p=1)

Attachments

(1 file)

This is occurring on all Windows for aurora branch, fr and en-US locales.

In the test, this ID is checked twice, first it should not exist, then it should.

I believe we fail here:

  // Even an element at the top of a page shouldn't exist when we hit the stop
  // button extremely fast
  var footer = new elementslib.ID(controller.tabs.activeTab, "footer-right");
  controller.assertNodeNotExist(footer);
Whiteboard: [mozmill-test-failure]
Somehow regressed by yesterdays checkins? I think about bug 793092. Can you reproduce the issue locally?
Priority: -- → P2
The test does not reproduce locally by running it alone in a loop 100 times.
I would assume that this is a somewhat fallout from bug 809431 but I cannot explain why. We don't see that for Nightly where it also has been landed. We should get this reproduced on one of the affected machines. I will try to do it later today. If I can reproduce it will be easy enough to figure out if the before mentioned bug is related or not.
This is very intermittent. I just tried to reproduce it on the machines we have seen this failure but I wasn't successful. Everything passed. I wonder if that's somewhat related to the network. We should wait a bit and get a clear picture on which factors it depends on.
Priority: P2 → P3
We got a massive amount of failures today across various branches but only on Windows. Any idea why it doesn't happen Linux and OS X?
Priority: P3 → P2
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure] s=130204 u=failure c=toolbar p=1
Assignee: nobody → andreea.matei
Status: NEW → ASSIGNED
Happened again today on Windows NT 6.0.6002 Service Pack 2 (x86) - Firefox 21.0a1 :
http://mozmill-ci.blargon7.com/#/functional/report/1641bc2f6438595b86015bd90153549a
I reproduced on win-xp-32-3 and it seems the click over stop works because stopButton.getNode().disabled is true after click as it should (the reload button appears).
The only thing left is that the page loads quickly, despite our listener. I'm searching for another event/listener to add and fix this.
Attached patch patch v1Splinter Review
Tested this on mm-win-xp-32-3 and on one heavy loaded OS X to check it's not affecting those slow machines.

Checking more often will prevent from having the test page load until the next check. Also we don't need 5s timeout, I tested with just 1s.

See reports here, those with 7 tests:
http://mozmill-crowd.blargon7.com/#/functional/reports?branch=21.0&platform=Mac&from=2013-02-12&to=2013-02-12

And from the win XP, since 13:39 PM:
http://mozmill-crowd.blargon7.com/#/functional/reports?branch=21.0&platform=Windows NT&from=2013-02-12&to=2013-02-12
Attachment #712918 - Flags: review?(dave.hunt)
Comment on attachment 712918 [details] [diff] [review]
patch v1

Review of attachment 712918 [details] [diff] [review]:
-----------------------------------------------------------------

So the page is loading too fast? This would be a great candidate for a screenshot on failure being useful! The change looks good to me, and loading pages 'too quickly' is a good problem to have! :)

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/a986e21aad97 (default)
Attachment #712918 - Flags: review?(dave.hunt)
Attachment #712918 - Flags: review+
Attachment #712918 - Flags: checkin+
Heh, yeah :)
I'll wait for results before checking backporting, cause this failure is on all branches.
No more failures on Nightly, patch applies cleanly to all other branches.
Great investigation Andreea. This fix is totally understandable. Thanks!
Happened again on Windows 8 x64 with Nightly:
http://mozmill-ci.blargon7.com/#/functional/report/90a0b225333a4e0c868fcb2b440a4125
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This hasn't failed since June
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → WORKSFORME
Not sure if WFM is the appropriate state here since this had actually a fix. After 3 months since the fix we had again some failure with this test, which should actually have been a different bug since we don't reopen fixed bugs after a while.
Resolution: WORKSFORME → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.