If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

offline:Mac - GUI - offline indicator hidden in message window

VERIFIED FIXED in mozilla0.9.4

Status

MailNews Core
Composition
P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: grylchan, Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9.4
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using 2001052908 build on MAC OS 9.0.4.

Noticed when you have a message in a separate window
(either a new message or a read message) that the offline
widget is partially hidden. You can still click on it
but from a display perspective it's hidden. Resizing
the window has no affect.

David I'm not sure you should be the one assigned to this
but wasn't sure who to assign this to.
(Reporter)

Comment 1

17 years ago
Created attachment 36454 [details]
Screen capture-check out the lower right hand corner

Comment 2

17 years ago
it's a toolkit bug, I would guess (not an offline bug, or even a mailnews bug).
Could you change it to a toolkit bug and assign it to the default owner, whoever
that is? thanks!
(Reporter)

Comment 3

17 years ago
ok David. Sorry for the trouble.
Reassigning it as a tool kit bug and removing all the
offline cc's.
(Reporter)

Comment 4

17 years ago
Reassigning to toolkit group
(Reporter)

Comment 5

17 years ago
ooppps trying to reassign again
(Reporter)

Comment 6

17 years ago
one more time change to toolkit
Assignee: bienvenu → trudelle
Component: Offline → XP Toolkit/Widgets
Product: MailNews → Browser
QA Contact: gchan → aegis

Comment 7

17 years ago
Needs some skin loving on that XUL to set up a margin, as was done for the 
security icon in other places.
Assignee: trudelle → hewitt
Component: XP Toolkit/Widgets → Themes
QA Contact: aegis → pmac
(Reporter)

Comment 8

17 years ago
Noticed the same thing in the 'Composer Window' also.
'Search Messages Window' about 1/4 of the offline widget is covered.

Comment 9

17 years ago
*** Bug 85950 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Adding back info lost when marking other bug as a dup.  nbaca, 0.9.3, P2, and
the fact that this also happens in composer window.
Priority: -- → P2
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 11

17 years ago
Not a themes bug - we need a resizer in the xul, just like all the other status
bars.
Assignee: hewitt → ducarroz
Component: Themes → Composition
Product: Browser → MailNews
QA Contact: pmac → sheelar
-->varada
Assignee: ducarroz → varada

Comment 13

16 years ago
*** Bug 90047 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Updated

16 years ago
QA Contact: sheelar → nbaca

Updated

16 years ago
Keywords: nsenterprise

Comment 15

16 years ago
We can handle this two easy ways that I know of.  One is to just create a 16
pixel padding in the skin for this window and windows like it.  The offline icon
would be shifted over for all platforms but it would fix the problem.  The
second way (which I would prefer) would be to put a XUL tag into that location
for Mac only that would be 16 pixels wide.  We have other things that are
platform dependent in the XUL, like OK/Cancel buttons.  There are a number of
places where something like this would make the Mac windows look better and this
solution would not mess up the appearance of Windows or Linux.  Please feel free
to send me this bug so that we can help.

Updated

16 years ago
Keywords: nsenterprise → nsenterprise+

Comment 16

16 years ago
Assigning to hewitt per varada.  hewitt will be fixing a number of windows that
have the same issue.
Assignee: varada → hewitt
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 17

16 years ago
Created attachment 47625 [details] [diff] [review]
patch to fix

Comment 18

16 years ago
sr=hyatt
r=ben@netscape.com
a=dbaron (on behalf of drivers)
(Assignee)

Comment 21

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: nbaca → olgam

Comment 22

16 years ago
Fix is verified on Branch build 2001-09-19.
I checked Offline Stand Alone window on Mac OSX and Mac 9.1.
Offline indicator is shown.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.