Print Preview Broken since last major Aurora update

RESOLVED DUPLICATE of bug 817342

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 817342
5 years ago
5 years ago

People

(Reporter: Woody Barrett, Unassigned)

Tracking

({crash})

20 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20130117 Firefox/20.0
Build ID: 20130117110358

Steps to reproduce:

Attempted to use print preview with any site


Actual results:

Firefox crashes


Expected results:

Print Preview should have been displayed
(Reporter)

Comment 1

5 years ago
I have submitted this bug via Mozilla Crash Reporter for the last 3 days.  Bug is simple - try to do a print preview on any page; Aurora crashes.  This behavior has been observed since the upgrade to v20.  Firefox Beta does not display this behavior.
(Reporter)

Comment 2

5 years ago
Printing normally still works.  Beta version that can successfully display Print Preview is 19.0, updated today (8:50 EST 18 Jan)
(Reporter)

Updated

5 years ago
Severity: normal → major
(Reporter)

Comment 3

5 years ago
Tried to display details in Mozilla Crash Reporter so that I could reproduce them here but Crash Reporter would not allow me to view the details - the "Details" button clicks but no details are displayed.  Sorry.
(Reporter)

Updated

5 years ago
Keywords: topcrash
Could you post your crash id? You can find it by typing about:crashes in the URL bar
Could you post any page which displays this behavior?
Does it reproduce in safe mode? (Help-restart with add-ons disabled)
Severity: major → critical
Keywords: topcrash → crash
(Reporter)

Comment 5

5 years ago
Crash IDs (prefix each with "bp-"):
76891dd8-395f-4fee-89bf-6f4422130116
ee67ee80-40f8-46dd-8e38-c76522130116
da1e4a23-e2b5-46f9-8bed-17fa42130116
8a9bedd6-00b7-4224-a1f9-be0c42130117
2b48334e-a327-47c3-9688-530ca2130117
7afc8076-1423-4864-8f43-75fdc2130118

Safe mode shows that the print preview crashes are definitely being caused by one of the add-ons.  I will disable each in turn and let you know what I find.
Thank you! Probably the add-on from bug 821733, comment 13?

I'll mark this as a duplicate of that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 821733
This can't be a duplicate of a metabug, by definition....  Please find the actual bug it's a duplicate of, if there is one.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

5 years ago
Assignee: nobody → general
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
(Reporter)

Comment 8

5 years ago
Not sure this is a duplicate, Virgil.  I also have Custom Buttons installed (I wish someone would start maintaining that add-on but that's another issue) but my testing shows that both IE Tab 2 (IE Tab 2(FF 3.6+) 4.12.22.2) and Ghostery (Ghostery 2.8.4) are causing the crashing.  I was disabling / enabling the add-ons 5 at a time and it was lucky that I disabled both of them at the same time, else I'd still be looking.  When either or both are enabled, the print preview crash occurs but when both are disabled, print preview works.
(Reporter)

Comment 9

5 years ago
Would you like me to enable these one at a time, crash Aurora, upload the crash results, then report the crash ID number to you?
(In reply to Boris Zbarsky (:bz) from comment #7)
> This can't be a duplicate of a metabug, by definition....  Please find the
> actual bug it's a duplicate of, if there is one.

The crash id links to the bug, whose comment 13 exhibits the same issue reported here. Not sure if it's worth having another bug opened for the same underlying issue, as bug 821733 already has the tracking flags set.

(In reply to Woody Barrett from comment #8)
The issue will probably be fixed by the bug mentioned in bug 821733. We'll probably ask you to watch this thread in case developers have any questions.
> The crash id links to the bug

That bug is a metabug.  It tracks _all_ crashes in this function, no matter what the reason.  There need to be separate bugs, blocking that one, for particular reasons.

> whose comment 13 exhibits the same issue reported here.

Great.  Was a separate bug filed for that comment?  If not, one needs to be.

> bug 821733 already has the tracking flags set.

What that means for a metabug is that all the bugs blocking it need to be tracked.  But you still need to file bugs blocking it for particular issues!

So let's start where we should have started: is this a problem on nightlies?

Comment 12

5 years ago
(In reply to Virgil Dicu [:virgil] [QA] from comment #10)
> The crash id links to the bug, whose comment 13 exhibits the same issue
> reported here
Bug 821733 comment 13 shouldn't have been in that bug. See bug 821733 comment 14.

Woody, does it happen in Nightly (http://nightly.mozilla.org/)?
(Reporter)

Comment 13

5 years ago
I'll check.  Give me an hour to install Nightly, duplicate my profile for it and keep my day job ;-)
Print-preview-with-addons crashes is bug 817342.  We were just waiting for additional manual testing before landing it on Aurora, so hopefully it will be fixed in the next few days.  Sorry for the trouble.
(Reporter)

Comment 15

5 years ago
Scoobi,

Installed Nightly with all updates, duplicated my Aurora profile for it and enabled IE2 and Ghostery.  Print preview works correctly - it appears that the fix for bug 821733 also works with this bug.  

Andrew, you say that these fixes should be moved into Aurora in the next few days?  I can go without Ghostery and IE2 for that long.

Thanks everyone, for all your efforts.

Comment 16

5 years ago
(In reply to Woody Barrett from comment #15)
> Print preview works correctly
Great to hear that.

(In reply to Andrew McCreight [:mccr8] from comment #14)
> Print-preview-with-addons crashes is bug 817342.
Let's dupe it to that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817342
You need to log in before you can comment on or make changes to this bug.