mega.co.nz isn't fully supported, it claims that Firefox is outdated

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: ekerazha, Unassigned)

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 704309 [details]
Alert screenshot

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

I tried to use the mega.co.nz website.


Actual results:

mega.co.nz claims that Firefox is an outdated browser and it can't fully support the website.

See https://mega.co.nz/#help_basics

Q: How do I install MEGA?
A: You do not need to install anything. MEGA is entirely browser based and works with all current major browsers. To unleash MEGA's full potential, we strongly urge you to use Google Chrome only.

Q: How do I upload files to MEGA?
A: There are three ways of uploading files to MEGA using your web browser:
1. Click on the red button on the start page
2. Go to your file manager and click on the "File Upload" or (if you're using Chrome) "Folder Upload" buttons near the top
3. Drag and drop files or (if you're using Chrome) folders onto the site

Q: Are there any file size limits on MEGA?
A: We do not impose artificial limits on file sizes other than your available cloud drive space. However, some legacy or technically inadequate browsers require the entire file to be stored in memory for downloading (Firefox, IE10, Opera), or for both downloading and uploading (IE9, Safari 5).

Moreover, when you login with Firefox, the website shows the attached alert where it complains about the HTML5 capabilities of Firefox.


Expected results:

Firefox should satisfy mega.co.nz requirements. Maybe we don't want to lose market share to Chrome because of this.
(Reporter)

Updated

6 years ago
Depends on: 704128
(Reporter)

Updated

6 years ago
Depends on: 748620

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
OS: Windows 8 → All
Hardware: x86_64 → All

Comment 1

6 years ago
(In reply to ekerazha from comment #0)
> Created attachment 704309 [details]
> Alert screenshot
> 
> User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101
> Firefox/18.0
> Build ID: 20130116073211
> 
> Steps to reproduce:
> 
> I tried to use the mega.co.nz website.
> 
> 
> Actual results:
> 
> mega.co.nz claims that Firefox is an outdated browser and it can't fully
> support the website.
> 
> See https://mega.co.nz/#help_basics
> 
> Q: How do I install MEGA?
> A: You do not need to install anything. MEGA is entirely browser based and
> works with all current major browsers. To unleash MEGA's full potential, we
> strongly urge you to use Google Chrome only.
> 
> Q: How do I upload files to MEGA?
> A: There are three ways of uploading files to MEGA using your web browser:
> 1. Click on the red button on the start page
> 2. Go to your file manager and click on the "File Upload" or (if you're
> using Chrome) "Folder Upload" buttons near the top
> 3. Drag and drop files or (if you're using Chrome) folders onto the site
> 
> Q: Are there any file size limits on MEGA?
> A: We do not impose artificial limits on file sizes other than your
> available cloud drive space. However, some legacy or technically inadequate
> browsers require the entire file to be stored in memory for downloading
> (Firefox, IE10, Opera), or for both downloading and uploading (IE9, Safari
> 5).
> 
> Moreover, when you login with Firefox, the website shows the attached alert
> where it complains about the HTML5 capabilities of Firefox.
> 
> 
> Expected results:
> 
> Firefox should satisfy mega.co.nz requirements. Maybe we don't want to lose
> market share to Chrome because of this.

No, first, someone should talk with Mega engineers about their needs.
Assignee: nobody → english-other
Component: Untriaged → English Other
Product: Firefox → Tech Evangelism
Version: 18 Branch → Trunk
Duplicate of this bug: 833259

Comment 3

6 years ago
Here is something you guys can use to test.

https://mega.co.nz/#!iNtX0JyI!QEKMfyd6KQfNfRV8CaAhOiSLEGoorrZG8iYeDXsYIIE

It does not work in FireFox 21, so this gives you a starting point to read their code to see what functions they need.

Comment 4

6 years ago
I can confirm that I am unable to finish dowload from Mega in Firefox. It reaches 100% and then nothing happens. No prompt to save the file appears.

Comment 5

6 years ago
I confirm that we could not use mega with Firefox 18.0.1 on Ubuntu 12.04 and with Flash 11.2.

We have this message:
"
Adobe Flash Player

Your browser requires the latest version of Flash to transfer files on MEGA"

But, Flash 11.2 is the latest version for Ubuntu. After that only Chrome could have Flash 11.2 +:
https://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html

https://mega.co.nz/#blog_1 
" Mozilla Firefox 18: Carefully avoids providing any API that would allow writing files from JavaScript."
(Reporter)

Comment 6

6 years ago
Firefox extension for mega.co.nz? https://twitter.com/KimDotcom/status/300228366697644032

Comment 7

6 years ago
Also the MEGA.co.nz blog says that "Mozilla Firefox Carefully avoids providing any API that would allow writing files from JavaScript." [1] I think that this may be one of the issues regarding the compatibility of Firefox with mega.co.nz . Also I guess that the HTML 5 File API isn't fully or is poorly implemented to support folder uploads on mega.co.nz and other websites that use the HTML 5 File API.[2]
! See links at the end of this post for more valuable information !
---
[1] 

https://mega.co.nz/#blog_1

https://mega.co.nz/#blog_9 

"Firefox Support

Coincidentally, one of the Mozilla Foundation's ten offices worldwide is located right around the corner from us, and we expect Firefox to soon join Chrome in being able to efficiently write local files from within JavaScript. As a temporary stop-gap solution, we have built a simple Firefox extension that does exactly that. It also maintains the path structure when downloading folders."

[2]

http://i.imgur.com/uwG076f.png - Firefox Supports only File Upload but not 

Folder Upload Feature like Google Chrome does (See the screenshot below):

http://i.imgur.com/fkYKOeB.png

Here is some more information about File API, Drag & drop feature for folders in HTML 5. This feature was implemented in Chrome 21.  
 
http://stackoverflow.com/questions/3590058/does-html5-allow-drag-drop-upload-of-folders-or-a-folder-tree

Here is a HTML 5 Experiment illustrating and explaining how to implement and make Folder Drag & Drop Feature work in HTML 5: 

http://blog.protonet.info/post/26894439416/html5-drag-drop-files-and-folders

Hope this helps and that it will be solved as fast as possible

Updated

6 years ago
status-firefox20: --- → ?
status-firefox21: --- → ?
status-firefox22: --- → ?
status-firefox23: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
tracking-firefox22: --- → ?
tracking-firefox23: --- → ?
status-firefox20: ? → ---
status-firefox21: ? → ---
status-firefox22: ? → ---
status-firefox23: ? → ---
tracking-firefox20: ? → ---
tracking-firefox21: ? → ---
tracking-firefox22: ? → ---
tracking-firefox23: ? → ---

Comment 8

6 years ago
FWIW I just downloaded a large (250MB) file from MEGA.co.nz successfully, without being offered an extension or whining about my browser choice.

Once the webpage finished downloading the file it then showed me a normal download dialog, (served as a "blob resource", according to the download manager) which then saved the file to disk instantaneously.

Maybe MEGA decided to fix their code.

Comment 9

6 years ago
I confirm that i could downlaod:
https://mega.co.nz/#!iNtX0JyI!QEKMfyd6KQfNfRV8CaAhOiSLEGoorrZG8iYeDXsYIIE

With Firefox 20 on Ubuntu 12.04 x89_64

I have no special extension for that and i don't have Flash on my Ubuntu.

Comment 10

6 years ago
On firefox 21 beta I'm still unable to download very large files from mega.co.nz
For example https://mega.co.nz/#!qIo3lRpS!UTkeP1xdEjNfNO6G9hbW4UR8KJ9BnD-USkHXa-NtlqA is almost 1GB and will consistently stop at about 67%.  Other files of similar size do the same while I can complete the download from IE9/10 or Chrome

Comment 11

5 years ago
I think this bug is actually fixed judging by Bug 704128 Comment 51. 

The last remaining item on MEGA's list [1] is selecting and uploading contents of a whole direcotry, which could be implemented by using the feature implemented in Bug 894840 (further improved in Bug 846931). 

[1] https://mega.co.nz/#blog_12
I just created an account in 26 Beta, uploaded a file, and successfully downloaded it in another window. No warnings about my browser of choice. Closing as fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.