Subfolders do not automatically refresh to show unread messages. If I click on the subfolders, then it rebuilds and then shows unread and sometimes makes ones that were previously read as unread

RESOLVED DUPLICATE of bug 905576

Status

MailNews Core
Database
RESOLVED DUPLICATE of bug 905576
5 years ago
2 years ago

People

(Reporter: cj.bell, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME bug 905576])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

Steps to reproduce:

I use a POP email account with a local provider.  On receipt of new mail, I have a filter that moves messages from certain people into subfolders of the Local Folders.  I'm running Thunderbird in Windows 7 pro 64bit.  


Actual results:

Often I'll see a notification icon by the clock of new mail, but when I look at my folders, none of them registers any new mail.  I have to click on each folder until I find one that needs to "build summary file".  After waiting for that to happen, it shows that there are new messages.  Often it will mark old messages as unread as well, almost as though there's no record of my previously having marked them read.  This has resulted in me missing important client information or directions in a timely fasion, nevermind the waste of time it is to have to rebuild summary files for folders just to check if new mail has arrived in them. 


Expected results:

when new mail is filtered into a folder, the folder should display new unread mail.   The summary files should be automatically updating and compiling.
(Reporter)

Updated

5 years ago
OS: Windows 8 → Windows 7

Comment 1

5 years ago
Yes, the summary files should be kept updated automatically and that is the normal operation. We need to find out why your's are getting outdated.

1. Be sure you are on TB 17.0.2.
2. tell us your filesystem type (NTFS or FAT32?).
3. do you use any antivirus that scans the files (realtime file protection) where TB stores the folders/messages ?
4. if you click any folder that then does "build summary file", does that same folder become outdated at a later time and you must click it again? Or is it always a different folder?
5. did you enable automatic compaction of folders in the TB options?
Component: Untriaged → Database
Product: Thunderbird → MailNews Core
(Reporter)

Comment 2

5 years ago
Hi

1.  I am currently  on 17.0.2
2.  The file system is NTFS.
3.  We use Kaspersky. and It's running in the background, but even with it disabled it seems to happen.
4.  Yes, the same folder may need to have the summary file rebuilt a few times, but usually only after having the software open for a few hours I'd say.  
5.  It was initially checked off to compact the folders, but I tried upping the MB size to 1000 MB and then tried simply leaving it unchecked.  It all seemed to behave the same. 

I should mention that I often have many emails saved in the folders.

Comment 3

5 years ago
Can you choose some folder that often rebuilds and rightclick it, choose Properties and then Repair? Then observe that folder if it rebuilds again in the future.
(Reporter)

Comment 4

5 years ago
Ok.  I've done the repair and will watch how it turns out.  Incidently a few of the folders showed a number of unread emails from days ago that had been previously marked read. 

Will update in a week or so.
(Reporter)

Comment 5

5 years ago
Still had the problems.  I looked at my configuration and my local folders were actually configured to be on a network folder.  I copied the folder locally and redirected the local folders path to the new local folder and the problem is gone. Everything works normally without having to rebuild the folder history all the time.

Will update if this changes and isn't really the fix.

Comment 6

3 years ago
Any news here? Has the moving of the storage helped?
Flags: needinfo?(cj.bell)
Phenomenon itself is pretty normal if "outdated msf codidition" is already generated in the subfolder where problem you saw.
1. When "outdated msf codidition" exists in FolderX, until FolderX is explicitly opened by folder click at folder pane, Rebuild-Index is not invoked.
    This is current design implementation.
2. When "outdated msf codidition" exists, copy/move mail to FolderX, filter copy/move to FolderX, doesn't invoke Rebuild-Index. (bug 495760)
    copy/move mail to FolderX, filter copy/move to FolderX, silently appends mail data to file named FolderX(not FolderX.msf),
    and because FolderX.msf is not usable due to "outdated msf condition", FolderX.msf is not updated, so mail count etc. is not refreshed at folder pane.
    This is mianly to avoid time consuming Rebuild-Index while downloding POP3 mails and filtering mails. 
3. When FolderX is clicked, Rebuild-index is automatically invoked.

"outdated msf codidition" can not perfectly avoided.
   Tb update msgDatabase in memory, aand appends mail data to FolderX(file size, timestamp is updated by OS).
   Before Tb rewrites data of msgDatabase  to FolderX.msf, power failure, system crash, crash in Tb happens.
"outdated msf condition while normally running" is also known. See bug 905576.

"outdated msf condition" can be easily generted by you, by "delete FolderX.msf", "restore backup of FolderX only, without restore of sync'ed FolderX.msf", "restore backup of FolderX.msf only", "interfere Tb's FolderX.msf writing by VirusScan of AV software, auto-backup etc.", and so on.
No such "Interfere of Tb's FolderX.msf file open/write" by you?
If no such interfere, penomenon like bug 905576 frequently happens in your environment?.
> then shows unread and sometimes makes ones that were previously read as unread

This is perhaaps bug 840418. Check X-Mozilla-Status: header in message source after you did sme actions such as bulk Mark as Read/Unread.

Comment 9

2 years ago
(In reply to :aceman from comment #6)
> Any news here? Has the moving of the storage helped?
Whiteboard: [closeme 2015-12-10][DUPEME bug 905576]

Comment 10

2 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(cj.bell)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-12-10][DUPEME bug 905576] → [DUPEME bug 905576]

Comment 11

2 years ago
unconfirmed in some sense, but wada's best estimate for bug 905576 is as good as it gets, so duping
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 905576
You need to log in before you can comment on or make changes to this bug.