Reconsider cairo thread safe support in favor OMTC rendering

RESOLVED DUPLICATE of bug 705691

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 705691
5 years ago
5 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Recently I've found one bug which in Debug build end with output:

gfx/cairo/cairo/src/cairo.c:437: _moz_cairo_destroy: Assertion `((*&(&cr->ref_count)->ref_count) > 0)' failed.

I've found reason of this abort, and found that context (SW) in Compositor thread destroyed by gfxContext DTOR in content thread.

I guess in order to use cairo and OMTC we should remove this line
http://hg.mozilla.org/mozilla-central/diff/5036a2b3fc8a/gfx/cairo/cairo/src/cairo-platform.h#l1.12

and add CAIRO_HAS_PTHREAD where it is possible.
Is this a dupe of bug 705691?
(Reporter)

Comment 2

5 years ago
Sounds like it is.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705691
You need to log in before you can comment on or make changes to this bug.