Last Comment Bug 832864 - FF18 uses much more CPU load than FF17 depending on the number of opened tabs
: FF18 uses much more CPU load than FF17 depending on the number of opened tabs
Status: RESOLVED INCOMPLETE
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 18 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 23:33 PST by netfreak
Modified: 2013-01-30 05:47 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description netfreak 2013-01-20 23:33:49 PST
I use FF always with many tabs opened, min 100, sometimes up to 300+. After Updating FF17 to FF18 I've recognized a much more higher CPU-usage.


This issue doesn't occur as long as there are just a few tabs opened, or it doesnt' be of any consequence at least. The CPU-load of FF18 gets higher with each opened tab. When you close the tabs, the CPU-usage also gets normal. There is nearly no Flash-content and just few JS working on the websites (thanks to NoScript and ABP). 


The System: i5-CPU, 16GB RAM, Win7 x64

FF17.01: CPU-load  1.0% average at 300 tabs

FF18.01: CPU-load 10.0% average at 300 tabs
FF18.01: CPU-load  5.0% average at 150 tabs
FF18.01: CPU-load  3.3% average at 100 tabs


A fresh install and disabling all addons except the 5 important ones (NoScript, ABP, Ghostery, Cookie Monster, Session Manager) didn't fix the problem. It seems, that FF is permanetly doing something with the tabs to being able to speedup on user-action. It's all good, as long as there are just a few tabs opened, but it's getting worse with each further opened tab.
Comment 1 Matthias Versen [:Matti] 2013-01-21 10:32:56 PST
This bug report is not actionable due to it's general nature and without Steps to reproduce (which URLs are loaded..)
Testing completely without extensions would be a minimum for a start.
Comment 2 Ioana (away) 2013-01-29 05:16:25 PST
If anyone can provide steps/details for reproducing this issue, please reopen the bug.
Comment 3 Carlos Velasco 2013-01-30 00:40:24 PST
Just opening this webpage makes FF 18.0.1 CPU go high:
http://www.fisiovivax.com

This don't happen using FF 17. I think it is related with JavaScript changes.
Comment 4 Ioana (away) 2013-01-30 05:47:31 PST
Carlos, please file another bug for the issue you are describing. This bug refers to  using Firefox with multiple tabs opened. Your issue reproduces with only one tab containing http://www.fisiovivax.com/.

Note You need to log in before you can comment on or make changes to this bug.