Last Comment Bug 832900 - Make test layout/mathml/tests/stretchy-and-large-operators.html work
: Make test layout/mathml/tests/stretchy-and-large-operators.html work
Status: RESOLVED FIXED
[mentor=fredw][lang=js][good first bug]
: helpwanted
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla21
Assigned To: Sunny [:darkowlzz]
:
: Anthony Jones (:kentuckyfriedtakahe, :k17e)
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 01:38 PST by Frédéric Wang (:fredw)
Modified: 2013-01-23 08:39 PST (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Made changes as per the comment (2.64 KB, patch)
2013-01-22 10:19 PST, Sunny [:darkowlzz]
no flags Details | Diff | Splinter Review
Made changes as per the comment (2.95 KB, patch)
2013-01-22 11:05 PST, Sunny [:darkowlzz]
no flags Details | Diff | Splinter Review
Made changes as per the comment (2.96 KB, patch)
2013-01-22 11:11 PST, Sunny [:darkowlzz]
fred.wang: review+
Details | Diff | Splinter Review

Description Frédéric Wang (:fredw) 2013-01-21 01:38:56 PST
layout/mathml/tests/stretchy-and-large-operators.html is an exhaustive test for the stretchy and large operators from our operator dictionary. However is does not work at the moment, because it incorrectly creates MathML elements with the createElement() function. The function createElementNS() (with the MathML namespace) should be used instead.

(See bug 755541 and 832713 comment 3)
Comment 1 Sunny [:darkowlzz] 2013-01-22 10:19:55 PST
Created attachment 704958 [details] [diff] [review]
Made changes as per the comment
Comment 2 Frédéric Wang (:fredw) 2013-01-22 10:28:00 PST
Thanks, that look good. I would put the MathML namespace string in a global variable rather than repeating it everywhere, but that's OK.

Be sure to try to conform to Mozilla's style guides: 80-character lines and a space after the commas.
(https://developer.mozilla.org/En/Mozilla_Coding_Style_Guide)

For the commit message, see a model here:
https://developer.mozilla.org/en-US/docs/Developer_Guide/Committing_Rules_and_Responsibilities#Commit_message_restrictions
Comment 3 Sunny [:darkowlzz] 2013-01-22 11:05:18 PST
Created attachment 705008 [details] [diff] [review]
Made changes as per the comment

Made some changes.
Created a global variable to supply namespace to all the creation code.
Comment 4 Sunny [:darkowlzz] 2013-01-22 11:11:45 PST
Created attachment 705011 [details] [diff] [review]
Made changes as per the comment

Added Bug number in commit message
Comment 5 Frédéric Wang (:fredw) 2013-01-22 11:47:34 PST
Comment on attachment 705011 [details] [diff] [review]
Made changes as per the comment

That looks good, thanks!
Comment 6 Frédéric Wang (:fredw) 2013-01-22 12:03:22 PST
Comment on attachment 705011 [details] [diff] [review]
Made changes as per the comment

I don't have commit access. But I put the checkin-needed keyword, so someone will take care of that relatively soon.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-01-22 15:31:09 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/36477d961bf2
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-01-23 08:39:32 PST
https://hg.mozilla.org/mozilla-central/rev/36477d961bf2

Note You need to log in before you can comment on or make changes to this bug.