POP-password cannot be empty / mail account concept

RESOLVED WONTFIX

Status

MailNews Core
Backend
--
enhancement
RESOLVED WONTFIX
17 years ago
8 years ago

People

(Reporter: m.mundt, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

1) Mozilla 0.9 _requires_ a password when receiving mail. Leaving it empty
results in a "Error getting mail password"-message. It would be better to allow
password with length=0.

Background:
Internally we use mail accounts which are not secured by passwords.


2) Imho it would be good, if both a server to receive (e.g. POP) and a server to
send (e.g. SMTP) would belong to _one_ mailaccount.

Nowadays I must choose a POP server to receive mail and separately choose the
correct SMTP server to send.

Better: select a account, which sets the POP (or IMAP) _and_ the SMTP values.

Background:
I have 2 accounts A and B with separate POP and SMTP servers.
After receiving mail by POP from B i want to answer it.
But server A doesn't let me send mail with the From-Field of account B. (and
vice versa)
So I must switch the standard SMTP server again and again instead of simply
selecting the account.


Reproducible: Always
Steps to Reproduce:
I think, it's clear from the description.
Exactly, these are not bugs but "misbehaviour".


Actual Results:  see description

Expected Results:  see description

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
change qa contact to ->nbaca
QA Contact: sheelar → nbaca

Comment 2

17 years ago
Have you tried defining your second account with its own SMTP server? For 
instance:

- Open Account Settings
- With the account selected the right panel displays "Account Settings", choose 
the Advanced button
- In the "Advanced Account Settings" dialog select the down arrow key to choose 
the SMTP server specific to the account selected, OK
- Select the OK button again to close Account Settings
- With account A selected, create a new message, change the From: to use the B 
account and send.

Comment 3

17 years ago
Marking nEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
This bug is technically INVALID because it describes two different issues in one
report.

But I think issue number 2 was fixed long ago (you can select the SMTP-server to
use with your Account via the "Advanced..." button in the "Server settings" and
you can change the accounts to answer the mail from with the drop-down-box
"From:" in the Compose-window).

Does issue number 1 still persist?

Keyser: Why did you mark this bug as NEW? Have you tested the empty mail
password case?
Product: MailNews → Core

Updated

9 years ago
Assignee: mscott → nobody
QA Contact: nbaca → backend
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 5

8 years ago
1) According to RFC 1939 a POP3 connection must be authenticated. Using the commands USER and PASS is one possible way. PASS is mandatory after USER. PASS needs a string as argument. Current code follows these requirements. The existence of non-authenticating mail servers in the wild shouldn't lead us to code this unconformal behaviour. Issue still exists, but WONTFIX.

2) Fixed in the past.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.