Closed Bug 833149 Opened 8 years ago Closed 6 years ago

[Browser] Search Suggestions

Categories

(Firefox OS Graveyard :: Gaia::Browser, enhancement, P3)

All
Gonk (Firefox OS)
enhancement

Tracking

(b2g18-)

RESOLVED FIXED
Tracking Status
b2g18 - ---

People

(Reporter: gkw, Unassigned)

References

Details

(Keywords: feature, Whiteboard: c=browser u=user, UX P1 [sprintready][UCID:Browser4, FT:Browser, KOI:P2])

Attachments

(1 file)

Build Identifier: 20130116230203
Git commit info: 3c84fa2b74b3dbe591f0d4fbedbac9aac...

On Desktop, search suggestions are supported, so we should consider supporting search suggestions on Firefox OS too.
Severity: normal → enhancement
Would like to have, but not on 1.x branch.
User story: As a user I would like to get search suggestions as I type so that I can save time by not having to type out my entire search query.
Summary: Support search suggestions → [Browser] Search Suggestions
Whiteboard: c=browser u=user
Priority: -- → P3
Whiteboard: c=browser u=user → c=browser u=user, UX P1
Flags: needinfo?(ibarlow)
Keywords: uiwanted
From bug 889577

"As a user when I am surfing the web, the Firefox OS browser should be offered search suggestions based off the selected search provider so that I may easily and quickly navigate to the search results page for my query.

*Users do not have the option to add their own search provider
*Product/Legal are working on partnerships with other search providers"
Duplicate of this bug: 889577
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/53549453
Ian - can you re-use the search suggestions spec for Fennec for this bug?
There was actually already some design work done specifically for FxOS here -- http://f.cl.ly/items/1J0U3q2f1E0n141B151s/browser-defaultsearch.pdf page 10 of this doc
Flags: needinfo?(ibarlow)
awesome - so to be clear, they can start with this spec for developing this feature now? or do you expect any changes to this (barring any discussion DURING development)
Yep, should be good to start here!
Brad - flinging this over the fence to see if it is sprint-ready from your perspective.
Flags: needinfo?(blassey.bugs)
Assignee: nobody → dale
Flags: needinfo?(blassey.bugs)
Keywords: uiwanted
Whiteboard: c=browser u=user, UX P1 → c=browser u=user, UX P1 [sprintready]
Assignee: dale → nobody
Assignee: nobody → bfrancis
Note: The UX spec we're using is the section marked "not in scope" in https://www.dropbox.com/s/dkg6rjgmsq6jpwj/browser-defaultsearch.pdf with the possible exception of page 13.
Work in progress patch, currently just prints content of search suggestions to the console.

Also fixes bug 908927.

Shelving this until we get more clarity on search requirements for 1.2.
Whiteboard: c=browser u=user, UX P1 [sprintready] → c=browser u=user, UX P1 [sprintready][UCID: Browser2, FT:Browser, KOI:P2]
Whiteboard: c=browser u=user, UX P1 [sprintready][UCID: Browser2, FT:Browser, KOI:P2] → c=browser u=user, UX P1 [sprintready][UCID: Browser4, FT:Browser, KOI:P2]
Whiteboard: c=browser u=user, UX P1 [sprintready][UCID: Browser4, FT:Browser, KOI:P2] → c=browser u=user, UX P1 [sprintready][UCID:Browser4, FT:Browser, KOI:P2]
I am working towards getting what you need via BD. Will keep you posted with timeframe, although not positive we'll be able to get this in time for 1.2.
Assignee: bfrancis → nobody
Attachment mime type: text/plain → text/x-github-pull-request
Closing since search suggestions added as part of Rocket Bar/Browser in 2.1.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.