Closed Bug 833215 Opened 8 years ago Closed 8 years ago

B2G RIL: Rename getFoo to readFoo in ICC Record

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla23

People

(Reporter: allstars.chh, Assigned: allstars.chh)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(2 files)

For ICC Elementary Files, the operations to read/write are called 'read' and 'update'.
For example, READ_RECORD/READ_BINARY, UPDATE_RECORD, UPDATE_BINARY.

However current functions to get those EF are prefixed with 'get', for example, getMSISDN, getMBDN, in order to make the naming to conform the specification, we should rename them to readMSISDN, readMBDN... etc.

Also I've spotted some different style to decode those parcels in ICC Record Helper, we should make the style consistent.
Assignee: nobody → allstars.chh
Attachment #736622 - Flags: review?(vyang) → review+
Comment on attachment 736623 [details] [diff] [review]
Part 2: Use the same style to parse.

Review of attachment 736623 [details] [diff] [review]:
-----------------------------------------------------------------

Please also check xpcshell tests :)
Attachment #736623 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/e9a1c44d1ca9
https://hg.mozilla.org/mozilla-central/rev/4bb7ccc2d743
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.