GCLI jsb should beautify embedded script tags

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
16 hours ago

People

(Reporter: spam_hole, Unassigned)

Tracking

18 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Open GCLI. Use "jsb http://google.com".


Actual results:

The output is mangled, since jsb interprets the page as containing just JavaScript code.


Expected results:

Based on the MIME type (text/html), jsb should attempt to beautify the source code of script tags. Otherwise, it is not very useful for examining pages with inline scripts (e.g. Google).

Updated

6 years ago
Component: Untriaged → Developer Tools: Graphic Commandline and Toolbar
Triage. Filter on Lobster Thermidor.
Not been worked on in 4 years, and I don't see that the priority of GCLI has increased in that time, so I don't think we need to keep it on file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 months ago
Product: Firefox → DevTools

Updated

16 hours ago
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.