Closed Bug 833273 Opened 12 years ago Closed 11 years ago

[Marketplace] Size of downloaded apps not displayed in market place

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:-)

RESOLVED INVALID
1.1 QE1 (5may)
blocking-b2g -

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Details

(Whiteboard: [TD-10263])

1. Title : Size of downloaded apps not displayed in market place
2. Precondition : Wifi connect
3. Tester's Action : Idle - Marketplace - Select business -   Download  Wified.com App - Displey "Install  wified .com  ? Pop-up"
4. Detailed Symptom (ENG.) : When the permission poup displays, the size will be displayed as "Unknown".
5. Gaia Source Version : a03f7b532e9998e646d55f93a0fc03a04d7ca7d9
6. Expected : The size of the application should be displayed.
7.Reproducibility: Y
1)Frequency Rate : 100%
8.Comparison Results : 
1)Model Comparing : 
9. Attached files: 
1)Log : 
2)Test Contents : 
3)Video file :
Invalid. That's expected behavior. When we don't know the size of what we're downloading, we list unknown. That will happen with apps that are hosted or packaged apps when there's no size specified.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
In case if size is unknown, shouldn't we remove the size field from the display. It doesnt make any sense to display the size as unknown.

Please know your opinion.
My suggestion is in case of hosted applications. In that case the size field is not mandatory. Hence cann't we display or hide the size field in the confirmation popup depending upon the presence of the field in the manifest file.

IMO displaying the size field as "unknown" to end user is not a good option.
Flags: needinfo?(jsmith)
Redirecting to Josh on that one.
Flags: needinfo?(jsmith) → needinfo?(jcarpenter)
(In reply to leo.bugzilla.gaia from comment #3)
> My suggestion is in case of hosted applications. In that case the size field
> is not mandatory. Hence cann't we display or hide the size field in the
> confirmation popup depending upon the presence of the field in the manifest
> file.
> 
> IMO displaying the size field as "unknown" to end user is not a good option.

"Unknown" was indeed specified in the original specs, but we also said "verbiage to be decided", so we were never very strongly attached to it. I agree that the word "unknown" could create a negative impression in the of the user, potentially discouraging them from completing their install. I'm fine with hiding the field when we don't know the size.
Flags: needinfo?(jcarpenter)
Fair enough, sounds like this is a valid bug then.
Blocks: app-install
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
blocking-b2g: --- → leo?
Whiteboard: [TD-10263]
Triage 4/12 - leaving Leo? as probably not part of the build but is a concern from the end user experience.
Whiteboard: [TD-10263] → [TD-10263] [NPOTB]
(In reply to Wayne Chang [:wchang] from comment #7)
> Triage 4/12 - leaving Leo? as probably not part of the build but is a
> concern from the end user experience.

No, this is part of the build. What this bug is about is basically requiring that in the case of installing an app where we do not know the size, we shouldn't display unknown - we display nothing.

FWIW, I do not think this blocks either unless UX thinks otherwise. This is polishing the UX here and not a critical UX fix either.
Whiteboard: [TD-10263] [NPOTB] → [TD-10263]
No matter whether 'unknown' or nothing displayed, this is not a blocker, but in triage we had a discussion about needing to be careful with these types of decisions - if we want the user to know there *is* a cost to an action, the original plan to show an "unknown" meets that better than absolute silence.
blocking-b2g: leo? → -
Flags: needinfo?(ffos-product)
(In reply to lsblakk@mozilla.com from comment #9)
> No matter whether 'unknown' or nothing displayed, this is not a blocker, but
> in triage we had a discussion about needing to be careful with these types
> of decisions - if we want the user to know there *is* a cost to an action,
> the original plan to show an "unknown" meets that better than absolute
> silence.

Correct. That might have been the original rationale for keeping "unknown" displayed here.
Leo, please see comment #9 for reasoning on why we think it is not a good idea to remove the size value. Does this make sense?
Flags: needinfo?(leo.bugzilla.gaia)
Dylan, The reasoning completely make sense for using "unknown" as the size for hosted applications. I agree using the same in case of unspecified size in manifests.

Thanks for responses.
Status: REOPENED → RESOLVED
Closed: 12 years ago11 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Resolution: --- → INVALID
No longer blocks: app-install
Flags: needinfo?(ffos-product)
Target Milestone: --- → Leo QE1 (5may)
You need to log in before you can comment on or make changes to this bug.