autofill text box does not work on all websites

RESOLVED DUPLICATE of bug 93776

Status

()

RESOLVED DUPLICATE of bug 93776
6 years ago
6 years ago

People

(Reporter: illumilore, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130107224407

Steps to reproduce:

after connecting to a wifi location, I am redirected to a login form. After filling in a username and password, I hit login. Firefox never prompts me whether it wants to remember the login or not, so when I come back to that login page, the username and password are not auto filled. 


Actual results:

I have no exceptions in the settings for remembering stored passwords.

Other browsers such as rekonq are able to remember and autofill these forms, so firefox not doing it is a bug.


Expected results:

  <form name="index" action="https://wireless.unm.edu/arubasec/index.html?cmd=login&switchip=10.80.0.50&userip=10.80.236.7&usermac=00:08:ca:69:0f:3d" method="post" autocomplete="off" onSubmit="return validate();">
    <label for="username"><strong>NetID: </strong></label><input name="auth_user" type="text" size="20"><br />
    <label for="password"><strong>Password: </strong></label><input name="auth_pass" type="password" size="25"><br />
    <label for="submit">&nbsp;</label>
    <input type="submit" value="Login" name="Submit" ;">
  </form>

Comment 1

6 years ago
Could you test with a fresh profile, please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Same behavior?
Flags: needinfo?(illumilore)

Comment 2

6 years ago
This is the expected behaviour when the autocomplete="off" attribute is used.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(illumilore)
Resolution: --- → DUPLICATE
Duplicate of bug: 93776

Comment 3

6 years ago
Good catch. *sigh*
(Reporter)

Comment 4

6 years ago
It still happens after I try it on a fresh profile
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

6 years ago
It's normal because Firefox doesn't store the password due to autocomplete="off".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 93776
You need to log in before you can comment on or make changes to this bug.