Closed Bug 833546 Opened 9 years ago Closed 9 years ago

Tabs menu forgets current selection of tabs view and opens automatically upon rotation

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 verified)

VERIFIED FIXED
Firefox 21
Tracking Status
firefox21 --- verified

People

(Reporter: aaronmt, Assigned: sriram)

Details

Attachments

(1 file)

STR:

i) Open a private tab, and switch to it
ii) Open the menu, and rotate the device to landscape
iii) Close the menu
iv) Rotate device back to portrait

--
Nightly (01/22)
Samsung Galaxy Nexus (Android 4.2)
Summary: Tabs menu forgets currently selection tabs view and opens automatically upon rotation → Tabs menu forgets current selection of tabs view and opens automatically upon rotation
Component: Theme and Visual Design → General
Attached patch PatchSplinter Review
The problem is that, on rotation the tabs-tray is re-inflated. This causes the item changed listener to be called -- when the last visited tabs was "Private" (as the inflated one has "Tabs" as selected entry).

To avoid this, the selection listener will show the tabs tray only if the tabs-tray was visible before rotation.
Attachment #705613 - Flags: review?(mark.finkle)
Attachment #705613 - Flags: review?(mark.finkle) → review+
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/b868c9ca7a0a - robocop was unhappy in testNewTab
This patch didn't cause the issue, hence pushing it in again:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cce24522fbf3
https://hg.mozilla.org/mozilla-central/rev/cce24522fbf3
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Verified fixed on:
-build:  Firefox for Android 21.0a1 (2013-02-15)
-device: Samsung Galaxy Nexus
-OS: Android 4.2.1
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.