Intermittent test_peerConnection_basicAudio.html | Exited with code -2147483645 during test run from "Assertion failed: !pctx->done_cb_timer"

RESOLVED DUPLICATE of bug 833557

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 833557
5 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19027422&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-2 on 2013-01-22 13:53:04 PST for push 059c7e8541e2
slave: talos-r3-w7-069

25987 INFO TEST-START | /tests/dom/media/tests/mochitest/test_peerConnection_basicAudio.html
++DOMWINDOW == 40 (4B76AF88) [serial = 3061] [outer = 0E1684D0]
[Parent 2724] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004003: file e:/builds/moz2_slave/m-in-w32-dbg/build/intl/uconv/src/nsCharsetConverterManager.cpp, line 301
[Parent 2724] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004003: file e:/builds/moz2_slave/m-in-w32-dbg/build/intl/uconv/src/nsCharsetConverterManager.cpp, line 301
[Parent 2724] WARNING: MediaPipeline Transport failed. This is not properly cleaned up yet: file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/media/webrtc/signaling/signaling_ecc/../../../../../media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp, line 278
[Parent 2724] WARNING: MediaPipeline Transport failed. This is not properly cleaned up yet: file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/media/webrtc/signaling/signaling_ecc/../../../../../media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp, line 278
[Parent 2724] WARNING: MediaPipeline Transport failed. This is not properly cleaned up yet: file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/media/webrtc/signaling/signaling_ecc/../../../../../media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp, line 278
[Parent 2724] WARNING: MediaPipeline Transport failed. This is not properly cleaned up yet: file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/media/webrtc/signaling/signaling_ecc/../../../../../media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp, line 278
Assertion failed: !pctx->done_cb_timer, file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/media/mtransport/third_party/nICEr/nicer_nicer/../../../../../../media/mtransport/third_party/nICEr/src/ice/ice_peer_ctx.c, line 460
TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/mochitest/test_peerConnection_basicAudio.html | Exited with code -2147483645 during test run
...
Thread 6 (crashed)
 0  mozalloc.dll!mozalloc_abort(char const * const) [mozalloc_abort.cpp:059c7e8541e2 : 30 + 0x0]
    eip = 0x71d91279   esp = 0x03904388   ebp = 0x03904390   ebx = 0x720f4ad0
    esi = 0x72041440   edi = 0x72040670   eax = 0x00000000   ecx = 0xb6b9b7ec
    edx = 0x7213e4d8   efl = 0x00000206
    Found by: given as instruction pointer in context
 1  xul.dll!MSCRTReportHook [nsAppRunner.cpp:059c7e8541e2 : 1384 + 0x8]
    eip = 0x6a56e9ac   esp = 0x03904398   ebp = 0x0390439c
    Found by: call frame info
 2  MSVCR100D.dll + 0x11babc
    eip = 0x720fbabd   esp = 0x039043a4   ebp = 0x0390c434
    Found by: call frame info
 3  MSVCR100D.dll + 0x114661
    eip = 0x720f4662   esp = 0x0390c43c   ebp = 0x0390c454
    Found by: previous frame's frame pointer
 4  MSVCR100D.dll + 0x11461a
    eip = 0x720f461b   esp = 0x0390c45c   ebp = 0x0390c47c
    Found by: previous frame's frame pointer
 5  MSVCR100D.dll + 0x489ed
    eip = 0x720289ee   esp = 0x0390c484   ebp = 0x0390c6b8
    Found by: previous frame's frame pointer
 6  MSVCR100D.dll + 0x12433d
    eip = 0x7210433e   esp = 0x0390c6c0   ebp = 0x0390c6c8
    Found by: previous frame's frame pointer
 7  MSVCR100D.dll + 0x115646
    eip = 0x720f5647   esp = 0x0390c6d0   ebp = 0x0390d180
    Found by: previous frame's frame pointer
 8  xul.dll!nr_ice_peer_ctx_stream_done [ice_peer_ctx.c:059c7e8541e2 : 460 + 0x1f]
    eip = 0x6bdda93a   esp = 0x0390d188   ebp = 0x0390d19c
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 833557
You need to log in before you can comment on or make changes to this bug.