send a distinct type for enumerated/categorical histograms in telemetry pings

REOPENED
Unassigned

Status

()

Toolkit
Telemetry
P4
normal
REOPENED
6 years ago
a month ago

People

(Reporter: froydnj, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Telemetry:P2])

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #811552 +++

- In the JSON (http://mxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/Histograms.json), certain histograms are of type "enumerated", meaning that they are categorical variables, whose outcomes represent distinct states, but whose ordering is usually not meaningful. At the moment, these are recorded as LinearHistograms, with buckets arranged approriately. I think it would make more sense to create a new histogram type for these, say CategoricalHistogram. 

They are not "linear", in the sense that the values are precisely integer values, not discretized continuous measurements, so they have a different interpretation. Also, bucket "0" is a proper state and does not correspond to "underflow". Because of this, in our analysis we separate these variables anyway (using the rule histogram_type=="linear" && bucket_count==range[2]+1) and handle them differently. I think it would be more robust to record these inherently as a separate type, following the schema in the JSON.
(Reporter)

Updated

6 years ago
Whiteboard: [Telemetry:P2]
(Reporter)

Updated

6 years ago
Summary: improvements for telemetry → send a distinct type for enumerated/categorical histograms in telemetry pings
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811552
Bug 811552 tracks multiple issues, this one tracks one specific issue.
Let's keep it open to have separate concrete issues.
Blocks: 1201022
No longer blocks: 811552
Status: RESOLVED → REOPENED
Priority: -- → P4
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.