cajastur.es - cannot get results from menu in this page, javascript errors

RESOLVED FIXED in Oct

Status

P4
major
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: xspuente, Assigned: pascalc)

Tracking

unspecified
Dependency tree / graph

Details

(Whiteboard: [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI][havecontact][bug248549fixed], URL)

(Reporter)

Description

18 years ago
I have a problem with this web page. It's a query and I don't get any results,
although IE gets them fine. I attached what the console says. 


Steps to reproduce:
1. Go to this page:
http://www.cajastur.es/generico.html?seccion=0107&contenido=/01/07/principal.html
2. Click in "Red de Oficinas"
3. A new page appears, with a menu to choose a location and get the bank
branches on that location. Choose any one, the fourth one "Avilés" is OK.
4. Click on the red button on the lower right corner, that says "Buscar".
5. A new window appears, and says "realizando búsqueda" (search in progress).
Nothing happens.
6. Do the same with IE, it works. And it shows you a list of 13 branches.

stdout directed to dynamic console
stderr directed to dynamic console
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
has multiple monitor apis is 1
Document http://www.ncbi.nlm.nih.gov/ loaded successfully
Document http://www.cajastur.es/generico.html?seccion=0107&contenido=/01/07/prin
cipal.html loaded successfully
JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/js/dynlayer.js line 80: ref.layers has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
chrome://navigator/content/navigator.js line 80: focusedWindow.location has no p
roperties

JavaScript error:
chrome://navigator/content/navigator.js line 80: focusedWindow.location has no p
roperties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/menus/inf01.html line 37: document.all has no properties

JavaScript error:
http://www.cajastur.es/servlet/Cajastur.c_oficin line 87: document.all has no pr
operties
Over to evangelism; looks like the site uses non-standard DOM.
Assignee: asa → bclary
Status: UNCONFIRMED → NEW
Component: Browser-General → Evangelism
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: doronr → zach
Hardware: PC → All

Comment 2

18 years ago
This site uses proprietary DOM and uses Dan Steinman's DynApi.
Blocks: 54458
Whiteboard: [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI]

Updated

18 years ago
Priority: -- → P4

Comment 3

18 years ago
-> Intl
Assignee: bclary → nitot
QA Contact: zach → momoi

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 4

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon
Summary: cannot get results from menu in this page, javascript errors → cajastur.es - cannot get results from menu in this page, javascript errors

Updated

17 years ago
Blocks: 113492

Updated

17 years ago
No longer blocks: 113492

Updated

17 years ago
Blocks: 124594
(Assignee)

Comment 5

16 years ago
The problem is not only this page but the whole interface which only works with
IE5+.

Setting the priority to Major since navigation is impossible.
Severity: normal → major

Comment 6

16 years ago
tech evang june 2003 reorg
Assignee: nitot → spanish
Component: Europe: West → Spanish
QA Contact: z-caillon-obsolete2 → spanish
(Assignee)

Comment 7

15 years ago
contact:
correo@cajastur.es
Whiteboard: [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI] → [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI][havecontact]
(Assignee)

Comment 8

15 years ago
Sent a letter
Assignee: spanish → pascal.chevrel
Target Milestone: --- → Oct
(Assignee)

Updated

14 years ago
Whiteboard: [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI][havecontact] → [BANKING][PROPRIETARY-DOM][TOOL][DYNAPI][havecontact][bug248549fixed]

Comment 9

14 years ago
Using the test case to reproduce the problem described appears to be fixed, but
i notice the sites images don't all load properly under Mozilla

Comment 10

13 years ago
I review this web again and seems the whole site has changed. I can navigate througt the site, including the Demo for the clients and works fine. I think we can close this bug.

Comment 11

13 years ago
one of the best references/recommendations I've found for encouraging financial institutions to support firefox is located at bankers on-line web site 

http://www.bankersonline.com/security/security_browserthreat070204.html 

It was written in 2004 during the download.ject attack, but much of it still applies today.  This is a good link to send when contacting banks.

Comment 12

11 years ago
Original URL is now 404. Like with comment 10, I can navigate around without any issues, so I'm marking this FIXED by the site redesign.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.