All users were logged out of Bugzilla on October 13th, 2018

B2G RIL: Expose SPN variables in nsIICCRecords

RESOLVED FIXED in Firefox 21

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: pgravel, Assigned: vicamo)

Tracking

unspecified
B2G C4 (2jan on)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: QARegressExclude)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Similar issue as Bug 828330

SPN related variables are not exposed by nsIICCRecords in nsIRadioInterfaceLayer.idl, which is needed by commercial RIL to display spn information.

The following variables need to be copied from nsIDOMMozMobileICCInfo in nsIDOMMobileConnection.idl to achieve parity

 readonly attribute DOMString spn;
 readonly attribute boolean isDisplayNetworkNameRequired;
 readonly attribute boolean isDisplaySpnRequired;
(Reporter)

Updated

6 years ago
Group: qualcomm-confidential
(Assignee)

Comment 1

6 years ago
I think it will be easier this way. :)
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830164
(Assignee)

Comment 2

6 years ago
As requested in bug 830164 comment #19, let's have a quick fix like what's done in bug 828330.
Status: RESOLVED → REOPENED
blocking-b2g: --- → tef?
Resolution: DUPLICATE → ---
blocking-b2g: tef? → tef+
Assignee: nobody → vyang
(Assignee)

Comment 3

6 years ago
Created attachment 705756 [details] [diff] [review]
explicitly export spn related attributes in nsIICCRecords
Attachment #705756 - Flags: review?(allstars.chh)
Attachment #705756 - Flags: feedback?(pgravel)
Attachment #705756 - Flags: review?(allstars.chh) → review+
(Reporter)

Comment 4

6 years ago
Looks good to me.
(Reporter)

Updated

6 years ago
Attachment #705756 - Flags: feedback?(pgravel) → feedback+
I'll help to push this change.
https://hg.mozilla.org/releases/mozilla-b2g18/rev/deb5185f2af9
status-b2g18: --- → fixed
status-firefox18: --- → wontfix
status-firefox19: --- → affected
status-firefox20: --- → affected
status-firefox21: --- → fixed
(Assignee)

Comment 8

6 years ago
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #5)
> I'll help to push this change.

Thank you :)
https://hg.mozilla.org/mozilla-central/rev/3226c8ac08f7
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
status-firefox19: affected → wontfix
status-firefox20: affected → wontfix
Target Milestone: --- → B2G C4 (2jan on)
status-b2g18-v1.0.0: --- → fixed
status-firefox18: wontfix → ---
status-b2g18-v1.0.1: --- → fixed

Comment 10

6 years ago
Does not make sense to create a regression issue.
Flags: in-moztrap-

Updated

6 years ago
Whiteboard: QARegressExclude

Comment 11

6 years ago
Cannot verify, need steps to blackbox test this issue.
You need to log in before you can comment on or make changes to this bug.