Intermittent B2G "InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?"

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19060798&tree=Firefox

b2g_ics_armv7a_gecko_emulator mozilla-central opt test mochitest-4 on 2013-01-23 11:40:39 PST for push 99dabf8d5e98
slave: talos-r3-fed-082

11:45:50     INFO -  INFO | runtests.py | Running tests: start.
11:45:55     INFO -  MOZPROCESS WARNING: ProcessHandler.waitForFinish() is deprecated, use ProcessHandler.wait() instead
11:51:01     INFO -  INFO | runtests.py | Received unexpected exception while running application
11:51:01     INFO -  Traceback (most recent call last):
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/tests/mochitest/runtests.py", line 748, in runTests
11:51:01     INFO -      onLaunch=onLaunch)
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/tests/mochitest/automation.py", line 1160, in runApp
11:51:01     INFO -      stderr = subprocess.STDOUT)
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/tests/mochitest/b2gautomation.py", line 258, in Process
11:51:01     INFO -      session = self.marionette.start_session()
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/marionette.py", line 327, in start_session
11:51:01     INFO -      self.session = self._send_message('newSession', 'value')
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/marionette.py", line 228, in _send_message
11:51:01     INFO -      response = self.client.send(message)
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/client.py", line 85, in send
11:51:01     INFO -      self.connect()
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/client.py", line 73, in connect
11:51:01     INFO -      hello = self.receive()
11:51:01     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/client.py", line 58, in receive
11:51:01     INFO -      status=ErrorCodes.INVALID_RESPONSE)
11:51:01    ERROR -  InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
11:54:10     INFO -  WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!
11:54:10     INFO -  INFO | runtests.py | Running tests: end.
11:54:11    ERROR - Return code: 1
https://tbpl.mozilla.org/php/getParsedLog.php?id=20688905&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20688868&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20688922&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20688841&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20689333&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20690205&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20690864&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20690828&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691069&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20690882&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20690164&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20692231&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691659&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691556&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691773&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691447&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691488&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20691549&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20692627&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=20692652&tree=Mozilla-Inbound
I'm bored with copy-pasting links, and since nobody has ever bothered to do anything about getting stacks in the logs, the links are useless anyway. If some hypothetical someone at some point before we just hide all your tests decides they want to know how often this is happening, https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=834016 should tell you.

Updated

5 years ago
Depends on: 843296
(In reply to Phil Ringnalda (:philor) from comment #67)
> I'm bored with copy-pasting links, and since nobody has ever bothered to do
> anything about getting stacks in the logs, the links are useless anyway.

I've been working on this in bug 843296 for the past couple weeks and just landed the patch on inbound.

This bug is pretty terrible, I'll make yet another post to dev.b2g/b2g-internal about this one.
(Another dozen failures since my last reply here, not pasting logs for a bit)
In order to get developer traction on this, we'll probably need to provide some more info.  Can we change our crash detection to handle startup crashes?  If that's hard, I can try to reproduce locally.
(In reply to Jonathan Griffin (:jgriffin) from comment #73)
> In order to get developer traction on this, we'll probably need to provide
> some more info.  Can we change our crash detection to handle startup
> crashes?  If that's hard, I can try to reproduce locally.

That's what I started working on yesterday. But I'm a little confused because ever since I applied the patch to check for crashes, the SIGSEGV messages stopped appearing in the logcat. I have no idea how this is even possible. For the record I was able to manually kill the b2g process and process the minidumps when testing locally.
Duplicate of this bug: 853007
(Reporter)

Updated

5 years ago
Blocks: 853024
This latest is a B2G process crash.  ahal, shouldn't our crash detection have been triggered for this?

Updated

5 years ago
Depends on: 892958
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.